Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

on an old PC, I have Lubuntu 12.10. during GIMP installation, the newest version was installed (ver. 2.8), but I think its a little heavy for an old machine like mine with a poor Intel Celeron CPU (Ram 1GB, VGA 128)

how can I go back to GIMP 2.6?

share|improve this question

4 Answers 4

Try doing the forward port approach (works for more packages than just Gimp):

  1. Add the precise main repositories to your system.

    Create a file like /etc/apt/sources.list.d/precise-for-gimp.list containing

    deb http://nl.archive.ubuntu.com/ubuntu/ precise main restricted
    deb-src http://nl.archive.ubuntu.com/ubuntu/ precise main restricted
    deb http://nl.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    deb-src http://nl.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    deb http://security.ubuntu.com/ubuntu precise-security main restricted
    deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
    

    Replace the mirror (here nl.archive.ubuntu.com) with the one you would like to use.

  2. Add a file with the appropriate pinning to allow downgrading of a certain set of packages, in e.g. /etc/apt/preferences.d/10-pin-gimp-to-precise:

    Package: *gimp*
    Pin: release a=precise-security
    Pin-Priority: 1001
    
    Package: *gimp*
    Pin: release a=precise-updates
    Pin-Priority: 1001
    
  3. Run sudo apt-get update

  4. Run sudo apt-get -s install gimp (-s to simulate only)

  5. Check whether the output makes sense. If not, and it can't manage to satisfy the dependencies, then consider reverting the actions above. If it does work, then actually run the actions to be performed by re-running the previous command without the -s option.

This approach will provide you best flexibility and security-update support, as it's just using the repositories rather than a specific version. It may be a PITA to set up, though.

share|improve this answer
    
While it installs and runs the splash screen, it segfaults and even crashes Unity in 12.10... –  gertvdijk Jan 17 '13 at 20:15
    
Worked perfectly for me (xubuntu 12.10). Thanks gertvdijk! –  Ash Mar 6 '13 at 10:58
    
@gertvdijk Could you please explain what this does? As I understand, this is the procedure you could use in general, if you want to use older versions of the programs on your system? If I should use Ubuntu 13.10, I understand I use saucy instead of precise –  Nickolai Leschov Dec 27 '13 at 13:23
    
@NickolaiLeschov This approach could indeed be considered general. It's forward porting an older application onto a newer Ubuntu distribution. precise is the source distribution in this example, so if you're running saucy, but you like a package version from quantal, use quantal here. Note it won't work always due to dependencies. –  gertvdijk Dec 27 '13 at 13:57
    
@gertvdijk Thanks! Ok, I see that precise is indeed the latest I can use if I want 2.6. –  Nickolai Leschov Dec 27 '13 at 14:09

You can also simply download gimp 2.6 from ftp://ftp.gimp.org/pub/gimp/v2.6/ and run

  tar xvfz gimp-2.6.x.tar.gz   # unpack the sources
  cd gimp-2.6.x                # change to the toplevel directory
  ./configure                  # run the `configure' script
  make                         # build GIMP
  make install                 # install GIMP

You can change the v2.6 in the url to change the version.

To first uninstall gimp:

sudo apt-get remove gimp
share|improve this answer
    
Yup, this is one way. But the general issue with compile from source is that it fiddles with your current dpkg-managed system files (so some may be overwritten later on updates) and it's hard to undo the steps taken in case the make install actions did something you didn't quite like. –  gertvdijk Jan 16 '13 at 16:51
    
you know gertvdijk, your way is pretty hard for me. im just a newcomer in linux. this solution is much simpler, but you said it gonna cause troubles. im really confused, so what should i do. isnt there a simple way without trouble? –  Merii Jan 16 '13 at 17:43
    
@Merii All will be pretty hard. Have you tried this approach in this answer? The ./configure step here will not run until you forward ported libgegl as well, for example. It's not an easy task to change versions of applications due to the high level of integration. This is intentional and how Ubuntu works. Consider sticking to 12.04 on an older PC. –  gertvdijk Jan 17 '13 at 20:50

You could try the wine emulator and install gimp version 2.6 as illustrated here on superuser.com:

http://superuser.com/questions/748488/linux-install-old-version-of-gimp

share|improve this answer

Try this (it worked for me):

sudo apt-get install ppa-purge
sudo ppa-purge ppa:otto-kesselgulasch/gimp
sudo apt-get install gimp
share|improve this answer
    
Downvote because the original question indirectly states that GIMP was updated. There's no reason to believe that the user is using a PPA version of GIMP. As such, the suggested answer is not relevant. –  Githlar May 1 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.