Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

we have ubuntu 10.04 and ubuntu 10.10 operating systems. However our software works only in these versions. We are facing some problems in the new versions 12.04 (LTS) we are working in it. But temporarily we need to setup a cacher server to install basic packages in these versions like samba, thunderbird, ssh ang plugins etc.. Any possibility's?

  • I already know that these versions has reached end of support. But we only prefer these versions, as it has a classic-gnome.
  • We are working to upgrade our softwares, so that we are in-need of a temporary solution.
  • Thought of setting up apt-mirror, but it consumes more bandwidth, for every release we need to download 85 GB's of datas, which is quite difficult and it takes lot of time.
  • Hope there is some better trick to acheive this task.

Update:

  • Any way to setup apt-mirror with needed packages?? Instead of downloading the whole mirror? We require only samba, ssh, thunderbird, flashplugin-installer and all additional plugins. For installing this packages, setting up a complete mirror of 85 GB per distribution is really waste.

  • We are already using apt-cacher-ng server. I am able to install packages for ubuntu 10.04 but installing packages in ubuntu 10.10 throws 404 error. Any way to fix this??

share|improve this question
    
"We are already using apt-cacher-ng server" <-- Next time, put this in your question from the very beginning. It's very relevant. –  gertvdijk Jan 16 '13 at 18:57

3 Answers 3

In our company we use apt-cacher-ng with very successful results. With this software we distribute updates to about 100 PCs running different versions of Ubuntu Linux without unnecessary waste of bandwidth.

This software also provides stats where you can see saved bandwidth

This software also provides stats where you can see the amount of saved bandwidth

share|improve this answer
    
Would be a good suggestion, but read my answer to another question as to why I think this particular application does not work very well currently. –  gertvdijk Jan 16 '13 at 10:56
1  
Didn't know about squid-web-proxy. I will have a look at it. Certainly we have to reboot apt-cacher-ng from time to time since it sometimes gets hung up with no apparent reason. –  jap1968 Jan 16 '13 at 11:11
    
That's exactly one of the issues I was having too. Also loads of corrupted packages after connection errors with complaining clients (Hash Sum Mismatch) about it. (refer to my previous link) However, it seems that the issues are being triaged and bugs are squashed as we speak. I do like the approach of apt-cacher-ng more, but at the moment it's not in a stable state. –  gertvdijk Jan 16 '13 at 11:22

You can do this with squid deb proxy:

And then on the clients you can change their sources.list to old-releases.ubuntu.com:

Then you'll have a cache of the older debs locally.

share|improve this answer
    
Hi @Jorge hope u can help. See my updated question. Do i want to make any changes to the repository in apt-cacher-ng server to get rid of 404 errors?? –  karthick87 Jan 16 '13 at 18:46
    
@karthick87 it's in his answer! See the second link. Apply this to your apt-cacher-ng configuration. –  gertvdijk Jan 16 '13 at 18:47
    
@gertvdijk Why configuration needs to be changed? It is same since beginning. Moreover apt-cacher-ng server works locally. Why do i need to make changes to repository pointings which uses internet? unless i install packages which is not stored in the caches? .. –  karthick87 Jan 16 '13 at 19:04
    
@karthick87 Just like the Squid-deb-proxy approach, you'll need to add remote repositories on the caching proxy not already enabled by the default installation. The old-releases.ubuntu.com is one of those not enabled by default. Similar to the instructions here –  gertvdijk Jan 16 '13 at 19:08

I would suggest to use squid-deb-proxy. It's just a pre-configured Squid proxy very well capable of caching packages from Debian/Ubuntu repositories efficiently. You can use all the power of Squid with it too.

For Squid-deb-proxy, just install the package squid-deb-proxy and add allowed destination domains in a new file in /etc/squid-deb-proxy/mirror-dstdomain.acl.d. The regular official Ubuntu mirrors are already added for you (e.g. *.archive.ubuntu.com). It will run a HTTP proxy at port 8000 by default.

As a bonus, clients can auto-discover caching-enabled machines in the local network by having the squid-deb-proxy-client package installed. If you prefer to configure this manually, configure APT yourself, e.g. /etc/apt/apt.conf.d/10proxy:

Acquire::http::Proxy "http://my.proxy.machine:8000/";

To add support for older releases, do this:

  1. Create a file /etc/squid-deb-proxy/mirror-dstdomain.acl.d/20-old-releases containing just this line:

    old-releases.ubuntu.com
    
  2. Restart the proxy: sudo service squid-deb-proxy restart.

share|improve this answer
    
How this works?? Could u pls explain in brief. –  karthick87 Jan 16 '13 at 17:15
    
@karthick87 I think I just did this in my answer. What's not clear exactly? –  gertvdijk Jan 16 '13 at 17:17
    
@karthick87 If it's about the older releases, I've just added it. –  gertvdijk Jan 16 '13 at 18:50
    
Thankyou :) i will try this solution. –  karthick87 Jan 16 '13 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.