Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After reinstalling Ubuntu 12.10 (due to a boot problem), each time I open LibreOffice Writer [Version 3.6.2.2 (Build ID: 360m1(Build:2))], two error messages pop up, both stating error loading BASIC of document

The first:

file:///home/ariel/.config/libreoffice/3/user/basic/Standard/script.xlb/:General error. General input/output error.

The second:

file:///home/ariel/.config/libreoffice/3/user/basic/Standard/dialog.xlb/:General error. General input/output error.

What is the cause of these messages and how can I correct them?

share|improve this question
    
I'm providing some links. See if they help. If they do, you can post an answer to your own question: forum.openoffice.org/en/forum/viewtopic.php?f=7&t=56961 ; forum.openoffice.org/en/forum/viewtopic.php?f=6&t=16588 ; ask.libreoffice.org/en/question/1641/… . OTOH, Onickyet's answer seems relevant. –  user25656 Jan 16 '13 at 11:03

1 Answer 1

LibreOffice is looking for these two files and can't find them. All you need to do is create the files. It's ok for the files to be empty.

The easiest way to do this is to issue commands in the terminal.

Close LibreOffice.

Use Ctrl+Alt+t to open a terminal. In the terminal you can copy and past the following commands. To paste in the terminal, use a right click and choose Paste from the popup menu, or click the scroll wheel on your mouse. Press Enter after each command. Enter commands one at a time.

cd ~/.config/libreoffice/3/user/basic/Standard

Check to see if the files are already there.

ls

If the files are there, something else is causing the problem. If they are not there, you just need to create them.

touch script.xlb

and after Enter

touch dialog.xlb

Restart Libreoffice.

share|improve this answer
    
Sorry. I'm a very basic user and don't know how to go that directory and how to create the new files. Will you kindly explain step by step? –  Ariel - user74152 Jan 16 '13 at 10:56
    
I read the links but yet I don't know how to do. –  Ariel - user74152 Jan 16 '13 at 12:30
    
Open a Terminal (for instance by pressing Control+Meta+T). Then type 'cd .config/libreoffice/3/user/basic/Standard'. With 'ls' you get the content of the directory listed. Then proceed with the steps mentioned above. –  0nickyet Jan 16 '13 at 14:17
    
When I pasted the first command to the terminal and pressed enter I got: ariel@ariel-MS-7592:~/.config/libreoffice/3/user/basic/Standard$ . Nothing else happened. I tried to create the two folders and restart Libreoffice but the same error messages are still there. –  Ariel - user74152 Jan 18 '13 at 8:13
    
The files "script.xlb" and "dialog.xlb" are where they were supposed to be, so the problem seems to derive from something else. –  Ariel - user74152 Jan 28 '13 at 17:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.