Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UPDATE - Removing my USB wifi dongle seems to cure the problem. So does disabling networking (but not disabling wifi alone). Now what? UPDATE 2 - The 'uptime' command says there are 2 users logged in. This will surely cause the behaviour I'm describing. I'm going to dig around and see if I can determine who the other user is. Nevermind, this was only due to the terminal I had open on the desktop.

If I log in to any account, choosing 'shut down' or restart takes me to the greeter. The same happens in the greeter itself - I am left there. No other users are logged in.

If I don't log in to an account after rebooting, the restart and shut down menu options in the greeter will work if I choose them immediately after the greeter appears. See a bootchart of this here: https://www.dropbox.com/s/ufb7s6ykvlbkjxj/jarlath-EP35-DS3-precise-20130116-3.png

If I wait 5 seconds or log in to a user account - they won't work. I've tested this several times. See a bootchart of this (logged in as user): https://www.dropbox.com/s/yx6jgoo2c7fy6pp/jarlath-EP35-DS3-precise-20130116-4.png

sudo -halt and sudo reboot both work as they should however.

I've output all processes from a logged in account (ps -A) and left them here: www.pastebin.com/e3WHtHYm

I assume that either an update, something new from the software center (not likely as I didn't install anything at the time) or a terminal command I issued is causing this. Here's my .bash_history from way before the problem began: pastebin.com/1DE5Tcd3

My kernel is 3.2.0-35, I tried also booting older kernels:

  • 3.2.0-32, 31, 30, 29, 26, 25, 24, 23, 22 -> No difference

As per suggestions in bug https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/838792 I tried:

  • Greped my /etc/init.d for services using su and removed 1 (ClamAV).
  • Killed PulseAudio

Neither of these helped. Some more context below;

    jarlath@jarlath-EP35-DS3:~$ cat /etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf 
[Configuration]
AdminIdentities=unix-group:sudo;unix-group:admin
jarlath@jarlath-EP35-DS3:~$ groups
jarlath adm cdrom sudo dip plugdev lpadmin sambashare vboxusers movies

From Logviewer, here is the output that is generated at the time I try to shutdown from the user menu:

auth.log
Feb 28 15:39:01 jarlath-EP35-DS3 CRON[15249]: pam_unix(cron:session): session opened for user root by (uid=0)
Feb 28 15:39:01 jarlath-EP35-DS3 CRON[15249]: pam_unix(cron:session): session closed for user root
Feb 28 15:39:16 jarlath-EP35-DS3 polkitd(authority=local): Unregistered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session6 (system bus name :1.114, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Feb 28 15:39:19 jarlath-EP35-DS3 lightdm: pam_unix(lightdm:session): session closed for user jarlath
Feb 28 15:39:22 jarlath-EP35-DS3 lightdm: pam_unix(lightdm:session): session opened for user lightdm by (uid=0)
Feb 28 15:39:22 jarlath-EP35-DS3 lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
Feb 28 15:39:25 jarlath-EP35-DS3 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "jarlath"
Feb 28 15:39:26 jarlath-EP35-DS3 dbus[580]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.184" (uid=104 pid=15385 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1438 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Feb 28 15:39:30 jarlath-EP35-DS3 lightdm: pam_unix(lightdm:session): session closed for user lightdm
Feb 28 15:39:30 jarlath-EP35-DS3 lightdm: pam_unix(lightdm:session): session opened for user jarlath by (uid=0)
Feb 28 15:39:30 jarlath-EP35-DS3 lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
Feb 28 15:39:34 jarlath-EP35-DS3 polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session9 (system bus name :1.198 [/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Feb 28 15:39:45 jarlath-EP35-DS3 dbus[580]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.208" (uid=1000 pid=15640 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1438 comm="/usr/sbin/console-kit-daemon --no-daemon ")


syslog
Feb 28 15:39:01 jarlath-EP35-DS3 CRON[15250]: (root) CMD (  [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null \; -delete)
Feb 28 15:39:16 jarlath-EP35-DS3 gnome-session[3479]: WARNING: Unable to load desktop file '/usr/bin/everpad.desktop': No such file or directory
Feb 28 15:39:16 jarlath-EP35-DS3 gnome-session[3479]: EggSMClient-WARNING: Desktop file '/usr/share/applications/everpad.desktop' has malformed Icon key 'everpad.png'(should not include extension)
Feb 28 15:39:16 jarlath-EP35-DS3 gnome-session[3479]: WARNING: Unable to find desktop file 'Transmission BitTorrent Client.desktop': Valid key file could not be found in search dirs
Feb 28 15:39:16 jarlath-EP35-DS3 gnome-session[3479]: WARNING: Unable to find desktop file 'gnome-Transmission BitTorrent Client.desktop': Valid key file could not be found in search dirs
Feb 28 15:39:18 jarlath-EP35-DS3 gnome-session[3479]: WARNING: Unable to stop system: Authorization is required
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.sleep-wake: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wifi: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wwan: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.enable-disable-wimax: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.network-control: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.system: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.own: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:20 jarlath-EP35-DS3 NetworkManager[1173]: <warn> error requesting auth for org.freedesktop.NetworkManager.settings.modify.hostname: (3) GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get UID of name ':1.126': no such name
Feb 28 15:39:21 jarlath-EP35-DS3 acpid: client 3292[0:0] has disconnected
Feb 28 15:39:21 jarlath-EP35-DS3 acpid: client 3292[0:0] has disconnected
Feb 28 15:39:21 jarlath-EP35-DS3 acpid: client connected from 15280[0:0]
Feb 28 15:39:21 jarlath-EP35-DS3 acpid: 1 client rule loaded
Feb 28 15:39:22 jarlath-EP35-DS3 acpid: client connected from 15280[0:0]
Feb 28 15:39:22 jarlath-EP35-DS3 acpid: 1 client rule loaded
Feb 28 15:39:26 jarlath-EP35-DS3 rtkit-daemon[2276]: Successfully made thread 15412 of process 15412 (n/a) owned by '104' high priority at nice level -11.
Feb 28 15:39:26 jarlath-EP35-DS3 rtkit-daemon[2276]: Supervising 7 threads of 2 processes of 2 users.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Successfully made thread 15416 of process 15412 (n/a) owned by '104' RT at priority 5.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Supervising 8 threads of 2 processes of 2 users.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Successfully made thread 15417 of process 15412 (n/a) owned by '104' RT at priority 5.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Supervising 9 threads of 2 processes of 2 users.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Successfully made thread 15418 of process 15412 (n/a) owned by '104' RT at priority 5.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Supervising 10 threads of 2 processes of 2 users.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Successfully made thread 15419 of process 15412 (n/a) owned by '104' RT at priority 5.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Supervising 11 threads of 2 processes of 2 users.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Successfully made thread 15420 of process 15412 (n/a) owned by '104' RT at priority 5.
Feb 28 15:39:27 jarlath-EP35-DS3 rtkit-daemon[2276]: Supervising 12 threads of 2 processes of 2 users.
Feb 28 15:39:31 jarlath-EP35-DS3 gnome-session[15446]: EggSMClient-WARNING: Desktop file '/home/jarlath/.config/autostart/everpad.desktop' has malformed Icon key 'everpad.png'(should not include extension)
Feb 28 15:39:36 jarlath-EP35-DS3 goa[15570]: goa-daemon version 3.4.0 starting [main.c:112, main()]
Feb 28 15:40:45 jarlath-EP35-DS3 dbus[580]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
Feb 28 15:40:45 jarlath-EP35-DS3 AptDaemon: INFO: Initializing daemon
Feb 28 15:40:45 jarlath-EP35-DS3 AptDaemon.PackageKit: INFO: Initializing PackageKit compat layer
Feb 28 15:40:45 jarlath-EP35-DS3 dbus[580]: [system] Successfully activated service 'org.freedesktop.PackageKit'
Feb 28 15:40:45 jarlath-EP35-DS3 AptDaemon.PackageKit: INFO: Initializing PackageKit transaction
Feb 28 15:40:45 jarlath-EP35-DS3 AptDaemon.Worker: INFO: Simulating trans: /org/debian/apt/transaction/dcf18c7d7f2c412a82d3288c2df8c094
Feb 28 15:40:45 jarlath-EP35-DS3 AptDaemon.Worker: INFO: Processing transaction /org/debian/apt/transaction/dcf18c7d7f2c412a82d3288c2df8c094
Feb 28 15:40:46 jarlath-EP35-DS3 AptDaemon.PackageKit: INFO: Get updates()
Feb 28 15:40:46 jarlath-EP35-DS3 AptDaemon.Worker: INFO: Finished transaction /org/debian/apt/transaction/dcf18c7d7f2c412a82d3288c2df8c094

Solution: I have found a solution. I am not using it as an answer as it doesn't identify the root cause, but for others who are happy with just a solution for themselves they should try this advise from grendndelman.net

Create a file named /etc/polkit-1/localauthority/50-local.d/usershutdown.pkla (the name must end in .pkla) and put the following in it:

[Allow Shutdown]
Identity=unix-user:*
Action=org.freedesktop.consolekit.system.stop-multiple-users
ResultAny=yes
ResultInactive=yes
ResultActive=yes

[Allow Restart]
Identity=unix-user:*
Action=org.freedesktop.consolekit.system.restart-multiple-users
ResultAny=yes
ResultInactive=yes
ResultActive=yes
share|improve this question
    
Use Ctrl+Alt+F1 to get to the virtual terminal. Login and delete ~/.Xauthority –  chaskes Jan 16 '13 at 3:38
    
As which user though? It seems to be a userless problem. –  TenLeftFingers Jan 16 '13 at 8:46
    
Use Ctrl+Alt+F1 to get to tty1, then login as yourself, then delete the file. If your X session crashed, the old file will prevent you from starting and stopping X and cause the issue with shutdown. If that's the problem... –  chaskes Jan 25 '13 at 7:35
    
I just tried it but no effect. Thanks anyway. I also tried doing it for every user (except guest) but still no luck. It seems to be directly related to networking. –  TenLeftFingers Jan 25 '13 at 23:20
1  
Done Alex L. Interesting you ask about groups. I was messing with them around the time the issue began in an effort to give other users access to the "Movies" partition which was owned by the movies user. –  TenLeftFingers Jan 28 '13 at 18:10

6 Answers 6

If more than one person is logged on pressing the shutdown button will take you to the greeter. You can still shut down with the command line with the command, sudo shutdown -h now

share|improve this answer
    
True, but there is only one 'person' logged in. Whether there is something else logged in as a user (eg a service) I don't know. –  TenLeftFingers May 8 '13 at 18:38

Try sudo halt. It would be interesting to find out if that, too sends you to the greeter.

share|improve this answer
    
sudo halt and sudo reboot work fine. I've updated my question to reflect that. –  TenLeftFingers May 8 '13 at 18:36

Even if this might not be your problem, a good tip for anyone coming by having this issue:

I thought I was having the same problem:

Turns out that "shutdown" doens't work if another session (SSH, ctrl-alt-f1, etc) is logged in.

In my case, the first time this happened I had an SSH session open to check for temps, but from that point on it was always some sort of "now check what happens in the logs"-session, making the problem be very consistent.

Quiting all ssh/other logins made the shutdown work again.

share|improve this answer
    
I was aware of that, since ssh counts as another log-in. But it's good to point out. –  TenLeftFingers Feb 1 '13 at 12:29

try to shutdown from terminal press ctrl + F1 then run sudo poweroff ,or just run sudo poweroff from terminal may this temporarily solve the problem

share|improve this answer
    
I have been doing that as a workaround - I could have mentioned it in the question. Thanks. –  TenLeftFingers May 21 '13 at 15:24

You can use the commands

users

or

w

to see if someone else is logged in somehow.

share|improve this answer
    
There is only one user logged in: tenleftfingers consols - Fri19 4days - –  TenLeftFingers May 21 '13 at 20:29
    
Can you post the output from the "w" command. If it says you logged on at Fri19 and have been idle for 4 days. That might be part of your problem. –  dan08 May 21 '13 at 20:44

You could force it. Make sure previous users LOG OUT instead of SWITCH USERS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.