Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed the instructions here and I got a dmg instead. This is what I entered:

cd Desktop
hdiutil convert ubuntu-12.10-desktop-amd64.iso -format UDRW -o ubuntu-12.10-desktop-amd64.img

Then it gave me a dmg. What should I do?

share|improve this question
Can you point where did you get that instructions? – Jorge Suárez de Lis Jan 15 '13 at 23:22
That's fine, it's not openable. But it can be converted and booted from. – Crissa Jun 19 '13 at 6:15

From that very same documentation:

Note: OS X tends to put the .dmg ending on the output file automatically.

It seems it's not a problem. Just continue to the next steps, and when prompted for the file name, be sure to provide the correct one, with the .dmg extension. That's all.

share|improve this answer
It still says 'no mountable file systems' when I click on the new file. Is this a problem? Should I just continue? – Skylar Ruloff Jan 16 '13 at 0:10
I don't know, I'm not a Mac OS X user. The instructions don't say a thing about clicking on the file, so I'd continue without worrying. – Jorge Suárez de Lis Jan 16 '13 at 0:44

Try this command,

hdiutil convert -format Rdxx -o ubuntu-12.10-desktop-amd64.img ubuntu-12.10-desktop-amd64.iso

Use Rdxx instead of UDRW.

share|improve this answer

Find the DMG file in finder and rename it to remove the trailing "dmg" extension. (Finder will ask you if you're sure. You are.)

Once you've done that, everything else will work as expected.

share|improve this answer

An .iso file and an .img file can normally be used interchangeably with little or no effect. Just rename the file so that it includes a .img extension.

cp ubuntu-12.10-desktop-amd64.iso ubuntu-12.10-desktop-amd64.img

If you get stuck, you can burn an image to DVD, as well as a thumb-drive.

share|improve this answer
When I try to open it, it says 'no mountable file systems' I tried renaming it and it doesn't work. I tried entering the command you suggestion and it didn't do anything. I am just trying to make a usb out of it so I can try it out. If it is this frustrating just to download then I might just say f- it and stick with osx – Skylar Ruloff Jan 15 '13 at 23:37
I'd try the DVD route before USB. See this to see why. – Chan-Ho Suh Jan 16 '13 at 0:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.