Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm very new to Ubuntu and this site as well. I've grown up on Windows and felt like trying something new. So here is my problem: I have a DELL Inspiron m5030 that got a virus so i reformatted and re-installed Windows but I guess the virus may have still been in there because my laptop still ran very slow and I ran a malware scan and it found some things even right after a factory reset.

So I decided to download Ubuntu 12.04 LTS, install it via DVD and chose the option to fully replace Windows. Everything seemed to work fine, no errors popped up and wile it was loading I could connect to my wifi and set up my user name and password. Once it was finished I tried logging in and it would just freeze when I hit enter after entering my password at the log in screen. I could still move my cursor around but no buttons or clicking did anything. I've tried re-installing and the same thing happened. So I've tried installing again but this time I've selected the option to auto-login. Then when I would reboot or power on it would just leave me at a blank screen.

I searched around on the web to find a solution and I found something that said when booting up hold the Shift key (getting to GRUB?), hit E, replace where it says something like quiet splash with acpi=off and then hit Ctrl+X.

That seemed to work and that is where I am typing this now. BUT now I have no little battery icon at the top left and no way of checking my battery status or charge. I also must replace the quiet splash with acpi=off everytime I reboot or power on. Also when I power down it gets stuck at a screen with some text and the last thing it says is 3168.221823 system halted. So then I must manually hold the power button to power off.

I'm sorry this is so lengthy but I tried to be as descriptive as possible so maybe I can find a solution.

share|improve this question
add comment

1 Answer

Don't rule out a hardware issue, either mobo, ram, or HDD. I had a fairly similar experience and it turned out to be a failing HDD. What fixed it was Spinrite, a HDD utility at:

http://www.grc.com/sr/spinrite.htm.

Its a bit pricey, but I've saved numerous systems with it.

share|improve this answer
    
Could the virus have caused a hardware issue? as far as i know my computer was running excellent on windows before the virus. Also my pc is only a little over a year old. its not the greatest but it has served me well when it was virus free on windows. –  Walker Jan 15 '13 at 23:27
    
Unlikely virus would cause hardware issue, but hardware issue can show up as a virus to some antivirus programs. There can be great variability between lifespan of individual hard drives. Is hardware most likely-- no. However, don't discount it. Do you (or a friend) have a spare HDD you can put in the laptop and then try to reinstall Ubuntu? I have 12.04 LTS 64-bit on an Inspiron n5110 with no problems. –  Doughnut Jimmy Jan 16 '13 at 1:56
    
I see. No i dont know anyone that has one but thats what i may have to end up doing. is it pretty easy to install a new hdd? are they interchangeable or do i need to get one made specifically for my model of computer? Thanks for the help btw! –  Walker Jan 16 '13 at 3:05
    
Hey Jimmy, im not sure what i did but somehow it is working just fine?!?! Battery icon has came back and it all seems to be working fine. I may have gotten it to 2d mode somehow during one of the menus i was in so maybe i needed to go from 3d to 2d? anyways hopefully it will stay like this. wish me luck –  Walker Jan 16 '13 at 3:30
    
glad to hear it. –  Doughnut Jimmy Jan 16 '13 at 17:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.