Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a long time spent with OS from boys from Redmont I would like to try something new. I decided to try some Linux editions, also Ubuntu Linux. I am completely new to this matter, this is also my first question here.

I am trying to install Ubuntu on VM created with VirtualBox. I installed succesfully Linux Fedora 2011 and Linux Mandriva, they are running well.

Unfortunately I cannot install any of the available Ubuntu versions. I downloaded and tried all four ISO files available on Ubuntu site (Ubuntu 12.10 32 bit and 64 bit, Ubuntu 12.04 LTS 32 and 64 bit) but none of them would work. 64 bits versions complain that my CPU is not 64bit compatible, 32 bit version complain that my CPU does not have proper functionality (PAE).

My CPU is intel i5-2430M. Maybe something else is wrong? But what could that be?

I appreciate your help.

share|improve this question
1  
Welcome to Ask Ubuntu! What is your host OS + architecture? I guess that if your host OS is not 64-bit then VirtualBox is not able to provide 64 bit functionality to guests either. Recent 32-bit versions of Ubuntu require the use of PAE by default, unfortunately. And do you have PAE enabled in VirtualBox? (Guest properties -> System -> Processor tab -> Enable PAE/NX checkbox) –  gertvdijk Jan 15 '13 at 10:48
    
@gertvdijk - recent virtualbox releases provide support for 64bit O/S's for 32bit hosts. –  fossfreedom Jan 15 '13 at 10:50
    
@fossfreedom True, but only if VT-x is enabled, right? –  gertvdijk Jan 15 '13 at 10:51
    
@gertvdijk - this one explains the caveats - askubuntu.com/questions/180761/… –  fossfreedom Jan 15 '13 at 10:53
1  
Also here is a note on PAE in virtualbox: askubuntu.com/questions/185701/pae-kernel-required-for-my-cpu - you also need to enable virtualization in your host BIOS. –  Takkat Jan 15 '13 at 11:04

1 Answer 1

in VirtualBox the Extended Feature PAE/NX is not enabled by default, once you make your virtual machine, before starting it, click the settings button for that machine, click system, then the processor tab, and put a tick in the PAE/NX to enable that operation,

also check the acceleration tab to make sure that hardware virtualization is enabled,

for more details on this or other virtualbox options visit the manual at https://www.virtualbox.org/manual/UserManual.html hope this helps and yes i know this answer is to a old post but thought to answer for people looking for a solution to this issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.