Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When typing Esc within an Emacs window under Unity (Emacs 23 standard package), the sound is turned on/off, but Emacs does not receive the key.

How can I change (probably) unity such that the Esc and also the other function keys are interpreted by Emacs?

A very crude workaround that always works in (GNU) Emacs is to use C-[ in place of Esc.

The question Why is the meta key is not working when using Emacs? does not apply because this was about using Emacs within a gnome-terminal, but I use Emacs directly under X.

Another option is to type Fn-Esc which produces ESC within Emacs and also works for the function keys; but I want the keys directly.

Edit: For some reasons that I cannot reproduce, Esc now works... It might be related to doing some xmodmaps.

share|improve this question
add comment

2 Answers

It looks to me like you are having some sort of function-lock enabled.

A simple way of accessing the meta key is to use the alt key.

share|improve this answer
add comment

This problem has been solved, probably by a recent update of 12.04. That is, when I press ESC I see now ESC- in the echo area!

Edit: The problem comes back after some time. But pressing Fn ESC gives one the real Escape key...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.