Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 12.10 in my laptop. I am not able to connect to my D-Link N150 Wireless Router which i was able to do when I had Windows XP.

The Problem

Everytime I log on to my Ubuntu, a window would pop up now and then saying:

"Authentication required by wireless network".

When I type in the password, the wireless icon would blink for a second and again the window pops up. I googled on this and followed all the steps to find out what is going wrong from my OS. I couldn't figure out anything.

Please help me to fix this issue.

What I Did

  1. Whether my wireless adapter is recognized?

    Yes it is. The below logs say that.

    sudo lshw -c network
    *-network
      description: Wireless interface
      product: PRO/Wireless 3945ABG [Golan] Network Connection
      vendor: Intel Corporation
      physical id: 0
      bus info: pci@0000:03:00.0
      logical name: wlan0
      version: 02
      serial: 00:1b:77:8e:46:61
      width: 32 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
      configuration: broadcast=yes driver=iwl3945 driver version=3.5.0-17-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
      resources: irq:44 memory:edf00000-edf00fff
    
  2. Whether my wireless device drivers are installed?

    I guess drivers for PRO/Wireless 3945ABG [Golan] by Intel are preinstalled in this Ubuntu version.The above logs driver=iwl3945 driver version=3.5.0-17-generic firmware=15.32.2.9 says that drivers are there. But i am not sure whether the version3.5.0-17 is supported by my wireless adapter 3945ABG.

  3. I tried this command rfkill list to see if the wireless is blocked?

    Soft blocked :no
    hard blocked  :no
    
  4. In my Network connection manager I have the following settings:

    • SSID: ********
    • Mode: Infrastructure
    • IPv4 settings - Method: Automatic (DHCP) addresses only
    • IPv6 settings - I have made it ignore
    • Wireless security : WPA & WPA2 Personal.

More Info

  • I have installed Ubuntu 12.10 from a USB stick where i was able to connect to my wireless network during installation.
  • The Additional drivers tab in the Software Sources center is empty. I have no idea why it is empty (if in case I need to install any extra drivers to fix this wireless problem of mine).
  • I have spent three days googling to fix this issue. I am still hopeful I would be able to fix this with yours help.

logs from var/log/syslog

12 wpa_supplicant[784]: wlan0: SME: Trying to authenticate with cc:b2:55:de:c6:b3 (SSID='BalaSourav' freq=2462 MHz)
12 kernel: [  192.089495] wlan0: authenticate with cc:b2:55:de:c6:b3
12 kernel: [  192.090744] wlan0: send auth to cc:b2:55:de:c6:b3 (try 1/3)
12 wpa_supplicant[784]: wlan0: Trying to associate with cc:b2:55:de:c6:b3 (SSID='BalaSourav' freq=2462 MHz)
12 NetworkManager[721]: <info> (wlan0): supplicant interface state: scanning -> associating
12 kernel: [  192.092577] wlan0: authenticated
12 kernel: [  192.096043] wlan0: associate with cc:b2:55:de:c6:b3 (try 1/3)
12 kernel: [  192.098785] wlan0: RX AssocResp from cc:b2:55:de:c6:b3 (capab=0x411 status=0 aid=2)
12 wpa_supplicant[784]: wlan0: Associated with cc:b2:55:de:c6:b3
12 kernel: [  192.100161] wlan0: associated
12 NetworkManager[721]: <info> (wlan0): supplicant interface state: associating -> 4-way handshake
14 kernel: [  194.003603] wlan0: deauthenticating from cc:b2:55:de:c6:b3 by local choice (reason=3)
14 NetworkManager[721]: <warn> Activation (wlan0/wireless): association took too long.
14 NetworkManager[721]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
14 NetworkManager[721]: <warn> Activation (wlan0/wireless): asking for new secrets
14 wpa_supplicant[784]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
14 NetworkManager[721]: <info> (wlan0): supplicant interface state: 4-way handshake -> disconnected
14 NetworkManager[721]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
14 kernel: [  194.034050] cfg80211: All devices are disconnected, going to restore regulatory settings
14 kernel: [  194.034061] cfg80211: Restoring regulatory settings
14 kernel: [  194.034068] cfg80211: Calling CRDA to update world regulatory domain
14 kernel: [  194.041065] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
14 kernel: [  194.041071] cfg80211: World regulatory domain updated:
14 kernel: [  194.041074] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
14 kernel: [  194.041077] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
14 kernel: [  194.041080] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
14 kernel: [  194.041083] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
14 kernel: [  194.041086] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
14 kernel: [  194.041089] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
23 NetworkManager[721]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
23 NetworkManager[721]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
24 NetworkManager[721]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
24 NetworkManager[721]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
24 NetworkManager[721]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
24 NetworkManager[721]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
24 NetworkManager[721]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
24 NetworkManager[721]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
24 NetworkManager[721]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
24 NetworkManager[721]: <info> Activation (wlan0/wireless): connection 'BalaSourav' has security, and secrets exist.  No new secrets needed.
24 NetworkManager[721]: <info> Config: added 'ssid' value 'BalaSourav'
24 NetworkManager[721]: <info> Config: added 'scan_ssid' value '1'
24 NetworkManager[721]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
24 NetworkManager[721]: <info> Config: added 'psk' value '<omitted>'
24 NetworkManager[721]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
24 NetworkManager[721]: <info> Config: set interface ap_scan to 1

(numbers are the seconds from the timestamp)

share|improve this question
    
Welcome to Ask Ubuntu! Could you provide the log entries in /var/log/syslog appearing from the time you attempt the connection to the moment the error message appears? That will probably give more information on what exactly happens. –  gertvdijk Jan 15 '13 at 10:25
    
NetworkManager[721]: get_secret_flags: assertion seems to indicate this is a bug. Assertions are severe errors. Have you tried updating all packages and reboot? (using wired network) –  gertvdijk Jan 15 '13 at 12:17
    
If i use command apt-get update, i believe this will try to update the packages installed in my system from their source via internet. But since i am not connected to the internet, what is the other way to do this? Please clarify. –  user123374 Jan 15 '13 at 14:47
    
Like I said, using a wired connection for example. This seems to be a bug, but might be fixed in an update. Better spend half an hour getting your laptop connected in an alternative way and apply updates rather than spending multiple days fixing up 0-day released software. :) –  gertvdijk Jan 15 '13 at 15:56
    
I tried sudo apt-get update and then sudo apt-get upgrade.Interestingly i did this in the same machine through a wired ethernet connection. I was able to connect to internet thru a wired connection but my wireless is still dead. I will try some more trial and error methods. –  user123374 Jan 16 '13 at 4:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.