Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I installed Ubuntu on my desktop, everything seemed to "just work" -- I used the proprietary ATI graphics card for my ATI Radeon HD 5870 and everything from Compiz to video to Amagetron Advanced worked perfectly fine.

Then I tried Minecraft. It crashes when rendering the levels, and Googling the error message shows it to be a common issue with (well, bug in) the proprietary ATI drivers. So, I tried disabling them -- and my entire desktop started flickering, Compiz exploded, and basically it was just Not Good.

I spent about $100 on this graphics card (last year), so I'd prefer to not pay for a new one if possible. On IRC, I've been told that "ATI sucks with Linux, your fault for buying a shitty card" and similar. I was hoping that Linux (especially Ubuntu) had gotten over the driver-hell as it had for the rest of my system -- is there a working, open-source ATI driver being developed?

share|improve this question
    
The problem with that 'driver-hell' is that most drivers for graphic-cards are proprietary. There are free drivers, too, but I'm not sure if they even support your card yet. –  Bobby Feb 1 '11 at 17:49
    
can you update your question with driver versions and confirm that you have all of the java libs installed (Specifically lwjgl)? –  ImaginaryRobots Feb 1 '11 at 19:31
add comment

3 Answers 3

The ubuntu wiki for the open source radeon driver indicates that it supports 3D acceleration for your card. My experience with recent versions of the radeon driver has been that it's slower but more stable than fglrx.

Unfortunately, replacing fglrx with the open source driver is a bit of a hassle. From here:

# remove fglrx packages
sudo /usr/share/ati/fglrx-uninstall.sh  # (if it exists)
sudo apt-get remove --purge fglrx* 

# remove and reinstall the open source driver
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon  
sudo apt-get install xserver-xorg-video-ati

# replace lingering proprietary libraries with the open-source versions
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
share|improve this answer
add comment

Generally speaking the open source driver doesn't work well when Compiz is enabled and a graphically intensive game is run. Minecraft might not look to pretty, but a lot is happening under the hood. The best advice I've seen is to turn off Compiz when running games.

As to developing a better open source driver, video cards are in an awkward position because the proprirtary drivers work well enough for most people, hence there isn't a significant push to improve the open source versions. That said, the ATI open source driver folks are still releasing new drivers regularly.

If you are willing to live on the cutting (or bleeding, as case may be) edge, you can try the xorg-edgers PPA, it is supposed to work better in some cases.

share|improve this answer
    
Can you explain how to install the driver (e.g. r600g for a ATI Radeon HD 4870 in my case) from the xorg-edgers PPA? I tried that yesterday and it was a pain.. –  Joschua Mar 15 '11 at 20:21
add comment

I had the same problem and i think to use Wine. It works but not at first time. I set the minectaft launcher to win XP configuration. It did not work. So I got angry and Choose Minecraft.exe and hold enter about 20s ens it starts many prosess and one of them START!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.