Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install Ubuntu Server 12.10 64-bit (also tried 12.04.1 64-bit LTS) with a RAID5 array but machine does not boot grub (I get the black screen with the blinking cursor), and I have tried


  • Four 2TB SATA drives (no hardware RAID)
  • Intel Server Board S1200BT w/Xeon E3 1200
  • 8GB RAM

I have tried numerous resources, and the Advanced Installation Docs from Ubuntu (which I followed) did not work as I expected.

Here are a few of the ways I partitioned and created SoftwareRAID for install, I used the Manual partitioning tool in the Ubuntu Server setup:

  1. Raid5 Device #0: 9GB SWAP, Raid5 Device #1: ~6TB ext4 /
  2. Raid1 Device #0: 1GB ext4 /boot, Raid5 Device #1: 9GB SWAP, Raid5 Device #2 ~6TB /

I have also tried putting /boot with the 'bootable flag = on' on drive 0, then using the setup listed in #1 above.

I can't seem to find anything relevant in the BIOS that might help this either, there are no settings or information regarding RAID.

Can anyone provide assistance? I am a novice at RAID and intermediate with Linux.

share|improve this question
up vote 0 down vote accepted

I solved the problem.

I set up the following partitions:

  1. Disk0: 250MB EFIboot, bootable = on
  2. RAID5 Swap of: Disk0 3.0GB, Disk1 3.0GB, Disk2 3.0GB, Disk3 3.0GB
  3. RAID5 /ext4 of remaining space on each drive
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.