Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a computer, I think it's running GNOME (it's running whatever the default is; I have the Unity panel,) and I installed LXDE for use on another user, but after installing LXDE, it will no longer lock the screen due to inactivity, or for any other reason.

When logging in, I have to enter my password, just like normal, but the screen cannot lock. Wait 5 mins (my setting, have verified this,) still unlocked. Press CTRL-ALT-L, no response. Even going to the gear and choosing "Lock Screen" has no result.

Even after deleting the second user account (just on a hunch,) the screen STILL cannot lock.

What do I need to do?

share|improve this question
    
Have you tried removing xscreensaver? –  Uri Herrera Jan 14 '13 at 22:32
1  
Try running sudo dpkg-reconfigure lightdm and selecting lightdm then restarting. Does that help the issue? –  Seth Jan 14 '13 at 23:16
    
Aha. sudo apt-get install gnome-screensaver fixed it. (I want to keep XScreensaver installed, as that's the only working option for LXDE.) Now I just have to figure out what to add to the startup file: gnome-screensaver --display=? I've tried numbers, but that doesn't work. EDIT: @iSeth, I just saw your answer, and tried that. So far, logged into the primary account, all is fine - will reply with info after logging into the LXDE account. –  JamesTheAwesomeDude Jan 15 '13 at 0:42
    
YES! Both users can now be locked without issue. –  JamesTheAwesomeDude Jan 15 '13 at 0:48

1 Answer 1

Okay, first, be sure GNOME Screensaver is installed (it's not really a screensaver manager, but more of just a daemon to handle locking/unlocking the screen):

sudo apt-get install gnome-screensaver

Then, reconfigure LightDM to incorporate the changes (credit to iSeth for the original suggestion,):

sudo dpkg-reconfigure lightdm

Finally, reboot. Everything will be fixed! Both LXDE and Unity/GNOME can now be locked without problems!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.