Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a few hard drives in mdadm RAID 5 configured to go to standby after a few minutes of inactivity. (Using hdparm.conf spindown_time.)

At irregular intervals I get messages like these in dmesg:

[ 1840.251661] ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 1840.251722] ata4.00: failed command: SMART
[ 1840.251758] ata4.00: cmd b0/d5:01:06:4f:c2/00:00:00:00:00/00 tag 0 pio 512 in
[ 1840.251759]          res 40/00:14:50:2e:04/00:00:02:00:00/40 Emask 0x4 (timeout)
[ 1840.251858] ata4.00: status: { DRDY }
[ 1840.251888] ata4: hard resetting link
[ 1840.600742] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 1840.601521] ata4.00: configured for UDMA/133
[ 1840.601547] ata4: EH complete
[337877.713988] ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[337877.714019] ata4.00: failed command: SMART
[337877.714038] ata4.00: cmd b0/d5:01:06:4f:c2/00:00:00:00:00/00 tag 0 pio 512 in
[337877.714039]          res 40/00:04:90:10:81/00:00:00:00:00/40 Emask 0x4 (timeout)
[337877.714089] ata4.00: status: { DRDY }
[337877.714107] ata4: hard resetting link
[337878.063085] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[337878.063743] ata4.00: configured for UDMA/133
[337878.063764] ata4: EH complete

I think the exception is caused by smartd when a drive does not wake up quickly enough.

There are no issues (that I can tell) in accessing the drives normally through the file system - it takes a few seconds longer than normal when they are asleep, but there are no exceptions.

Is this something I should worry about, as a potential symptom on something that could corrupt a drive over time?

Or can I safely ignore it as part of normal operation?

Edit:

By request: smartctl -a for sdaand sde, both disks are members of the array.

If ata4is the same as scsi-4 then sde is the one that gave the error above, according to /dev/disk/by-path.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Provide the output of the command smartctl -a /dev/sda (replace sda with all disks) and post on http://paste.ubuntu.com/). This will show whether your disks are trying too often to spin down in order to save energy (which may damage them). In addition, it will show other information such as temperature, and bad sectors.

share|improve this answer
    
Also do this while they are spun down and see if you get the same error. You also might want to configure smartd to not poll the smart data while the disk is in standby to avoid waking it up unnecessarily. –  psusi Feb 1 '11 at 18:49
    
@user4124 Added for two of the disks, the rest are similar - same model, same age, similar SMART values. –  j-g-faustus Feb 1 '11 at 18:50
    
@psusi No errors from a couple of smartctl runs from the command line. But in this log there are almost four days between the two errors - five disks, smartd runs once a day and four days between errors should indicate it happens ~1 in 20 wakeups. But yeah, I can try to disable smartd polling on standby disks. –  j-g-faustus Feb 1 '11 at 19:04
    
The paste.ubuntu.com/561078 reports look fine to me. I would not worry for these disks. The error messages are for SMART accesses and as psusi says, get smartd not to poll the disks when in standby. –  user4124 Feb 1 '11 at 19:36
    
@user OK, will do. Thanks for the feedback to both of you. –  j-g-faustus Feb 1 '11 at 19:45
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.