Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a netbook with a N450 Atom and a BCM70012 aka Crystal HD card. On Windows 7 I can play HD flash video with very little CPU usage because of the RC of Flash 10.2. I did some reading and saw posts claiming that the Crystal HD card is finally supported by the newer Flash 10.2 RC in Ubuntu but I can't get it to work.

I can confirm that flash 10.2 is loaded and used, and there's even a HW acceleration option that is enabled in the settings but performance is horrible. From what I read, the Crystal HD card is supposed to be enabled on 10.10 by default - I don't know if it is. I tried installing drivers for it in various ways but HD flash video is still a slideshow

So does anyone have it working? If so, how'd you set it up?

share|improve this question

2 Answers 2

As of tonight, i've been able to succesfully have hardware acceleration in Flash Player (youtube 1080p videos running smoothly). I had to:

  1. Checkout and compile the latest crystalhd tree from git (http://git.wilsonet.com/crystalhd.git/)

  2. Download adobe flash player 10.2 (latest release, it should come as an update if you have flashplugin-installer Install flashplugin-installer

  3. Add the following lines to the /etc/adobe/mms.cfg file (create it if you don't have it already):

    EnableLinuxHWVideoDecode=1
    OverrideGPUValidation=true
    

Hope it helps!

share|improve this answer
    
Oh wow, thanks for letting me know about this. Also, is it stable? I remember, sometimes I would seek in Totem while using crystal acceleration it would throw a wobbly and lock up the whole system. Also, are you on 10.04 or 10.10? –  jbeard4 Feb 11 '11 at 4:27
    
Not very stable, actually ... this morning it's broken again! :\ And I'm on 10.10, btw –  dcapocelli Feb 11 '11 at 6:08
    
I can confirm that it flash playback actually works. However, it is very very unstable and unusable. From what I've noticed, it can play only 1 video from the browser (using flash). When you close the browser or open up another video, Ubuntu itself will crash/freeze. I had to press/hold the power button to manually shut it off. BTW. I'm using Chromium Stable + Ubuntu 10.10. Any updates/fixes on this? –  user11788 Mar 3 '11 at 21:50
    
as of today's latest flash update, and using drivers from git repository (last update from march 14th) things seem go a lot better! –  dcapocelli Mar 23 '11 at 18:04

The BCM700xx card can only handle one thread at a time. If you open another window, the second thread will be processed by the CPU. You have to completely close the window with the original video before you start another if you want to utilize the BCM700xx. Remember, one thread at a time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.