Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed xubuntu-desktop ontop of a stock Ubuntu installation.

When using ssh, or more specifically git, I always get this warning

WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-IVaeDO/pkcs11: No such file or directory

I have done a fair amount of googling to disable/enable the proper services at boot time, but so far I always end up with this error.

Any insight on completely removing gnome-keyring, and it's downfalls, OR integrating gnome-keyring into xubuntu/xfce would be awesome.

share|improve this question

3 Answers 3

up vote 18 down vote accepted

You get this warning because gnome services such as gnome-keyring-daemon and gnome-settings-daemon are not normally running when you are logged into a Xubuntu or Xfce session.

However, the quick fix that has worked for me is to go to the menu and choose settings > settings manager > session and startup > advanced and enable Gnome services (see screenshot below). Now, all installed Gnome services will start when you login, and you should be able to use the functionality of gnome-keyring-daemon (although further configuration may be necessary, as I note below).

enter image description here

It is important to note that you will have to logout and login again for this to take effect, and then services such as these will be running (if you have already have installed them with gnome applications):

enter image description here

You may need to tweak other things in the Xfce/Xubuntu session, depending on how you wish to use gnome-keyring-daemon. There are some references to using it with ssh on this blog and many others out there, but there can be problems to overcome with using it on Xubuntu.

It is too big of a topic to produce a general answer on the pros and cons of gnome-keyring, but these hints should enable you to begin integrating it into a Xubuntu session.

However, if these suggestions don't solve the problem, you may be a victim of the problem described at Launchpad regarding gnome-keyring.

share|improve this answer
2  
Thanks, Any tips on how to go the other direction and remove all gnome stuff and still have ssh-agent and ssh-add run at boot? –  winchendonsprings Jan 17 '13 at 18:50
    
@winchendonsprings ssh-agent and ssh-add are part of the openssh-client package, which doesn't depend on any gnome applications or services, so it might be possible, but I'm not sure on this. –  user76204 Jan 18 '13 at 12:09
    
what version of ubuntu is this for? Don't see all this options on 12.04 LTS –  sureshvv Jul 8 '13 at 7:19
    
@sureshvv Xubuntu 12.04 and later; the options are definitely available in Xubuntu 12.04. Go to settings > settings manager > Session and Startup > Advanced. –  user76204 Jul 11 '13 at 19:41
    
@Mik What is the command for displaying that box? I would like to try this on Fluxbox. –  rvf0068 Oct 24 '13 at 18:53

Under a Bourne shell, you can turn off gnome-keyring and get rid of this warning by running:

unset GNOME_KEYRING_CONTROL

to remove the gnome keyring path from your environment variables. You can also put this command at the end of your ~/.bashrc file.

Under a C shell, the equivalent command is:

unsetenv GNOME_KEYRING_CONTROL

and the command can be put at the end of your ~/.cshrc file.

share|improve this answer

Another way to get rid of that pesky warning (I got this in XFCE):

The trick is to add "LXDE;XFCE;" on the line with OnlyShowIn= (without the double quotes and plus the semicolon, didn't try without it) to this file "/etc/xdg/autostart/gnome-keyring-pkcs11.desktop" by editing it with whatever text editor you prefer, I'll use "nano"

1 - in a terminal type (as root or with sudo):

# nano /etc/xdg/autostart/gnome-keyring-pkcs11.desktop

[Desktop Entry]
Type=Application
Name=Certificate and Key Storage
Comment=GNOME Keyring: PKCS#11 Component
Exec=/usr/bin/gnome-keyring-daemon --start --components=pkcs11
OnlyShowIn=GNOME;Unity;LXDE;XFCE;
X-GNOME-Autostart-Phase=Initialization
X-GNOME-AutoRestart=false
X-GNOME-Autostart-Notify=true
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-keyring
X-GNOME-Bugzilla-Component=general
X-GNOME-Bugzilla-Version=3.2.2
NoDisplay=true
X-Ubuntu-Gettext-Domain=gnome-keyring

2 - after editing, make sure you save the changes

3 - restart computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.