Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't disable the Guest session for Ubuntu 12.04.

I tried to add allow-guest=false but it doesn't work.

Is there another way to disable it?

share|improve this question
    
Have you tried the other methods mentioned in: askubuntu.com/questions/62564/… –  david6 Jan 14 '13 at 20:52
    
Are you sure you are using Lightdm with the Unity greeter (the default greeter)? Can you post all the contents of your file /etc/lightdm/lightdm.conf? –  Jorge Suárez de Lis Jan 14 '13 at 22:21

3 Answers 3

You can use the method explained here: How to disable the guest account via the GUI?

Short version: Install the ubuntu tweak from here: http://ubuntu-tweak.com/
Goto Ubuntu Tweak > Tweaks > Login Settings > Guest Account > OFF

share|improve this answer

First you need to hit CTRL+ALT+T to open the terminal. When you've opened the terminal you need to type: sudo sh -c 'echo "allow-guest=false" >> /etc/lightdm/lightdm.conf'
When you did that restart the computer and that's done ;)

share|improve this answer

Just follow the steps to disable the Guest account

http://dcageek.blogspot.com/2013/06/how-to-enable-disable-guest-account-in.html

share|improve this answer
1  
Welcome! Usually on this site it's considered good practice to outline the entire solution and then provide the link afterwards as a reference; answers should stand alone, otherwise if the link rots for whatever (linked site is taken down, for instance) it no longer provides any help for a future user seeing it. –  Jez W Jun 21 '13 at 13:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.