Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2006 Macbook (Black), Intel Core 2 Duo and 2GB RAM. Recently while cleansing the inside of dust with a hint of compressed air, I had removed the hard drive, the RAM, and the screws securing the case in place. Upon replacing all of the above I was met with the GRUB menu. I simply hit enter to select Ubuntu, but nothing happened.

I came across that the keyboard was not working. I know that the keyboard is not damaged, the power button works and it's on the same connection as the keyboard to the logicboard. I read extensively on how to enable my keyboard, and I attempted to use an external USB keyboard with no avail.

With out the BIOS readily available since it is a Macintosh brand computer, I cannot enable legacy USB support. With the CD drive enabled it automatically boots to CD over the hard drive, but again once asked to either "Try" or "Install" Ubuntu, the mouse no longer works and the keyboard is also inactive.

Could the problem here be software, or is it more likely hardware (torn ribbon)?

share|improve this question
I assume you've already tried this but as a troubleshooting step have you tried plugging the keyboard into different USB ports? Particularly if, for example, you're currently plugging it into a USB port on your monitor or other hub, or something. – thomasrutter Jan 15 '13 at 4:24
With a reinstall of Ubuntu 12.10, the GRUB bootloader does not work with external keyboard but before I encountered the GRUB loader, I was able to use the external keyboard and mouse in Ubuntu 12.10. – etsr Jan 17 '13 at 1:39
up vote 0 down vote accepted

Update: The GRUB bootloader will only work with the keyboard that is installed on the laptop, and not a USB keyboard (At least with EFI booting and without access to the traditional BIOS). After an Ubuntu reinstall I was able to determine the cause of the problem was not software. I fully removed the cable that was was linked to the logic board and found there to be creases and wrinkles along a single fold towards the forward end of the ribbon. I am suspecting that this is what caused the damage, and the only solution is to order a new ribbon.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.