Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Lubuntu 12.10 and everything was going fine until yesterday. Whenever I try and use an SD card or USB stick/USB hub it won't recognize it in the file manager.

I ran lsusb which recognized the Kingston Datatraveler USB that I'm trying to use, but when I ran ls /dev/sd* it came up with

/dev/sda /dev/sda1 /dev/sda2 /dev/sda5

WITH the USB stick still in. I took the USB stick out and tried it again and came up with the same results.

enter image description here

share|improve this question
    
i'll outline quickly the reasoning why i had him run those commands: lsusb returns the USB hub stuff, and ls /dev/sd* returns the partitions, and disks should theoretically show the USB stick if it's there. –  jrg Jan 14 '13 at 16:28

2 Answers 2

I tried a number of ways (and the answer above), but didn't get anywhere on my system which was having the same issues. Then I had a brain-wave and looked in the "user settings" from the gui menu.

It seems the ability to mount drives is disabled for user profiles by default.

Click on the "Advanced Settings" for the user that needs to have access to external media, switch to the "User Privileges" tab and then put a tick/check in "Mount user-space filesystems (FUSE)". I'd review what else is disabled while you are there, as it may solve other problems!

It got my system working how I expected it to, and I hope this answer helps others.

share|improve this answer

its been awhile since I had to do this but. here is what you will want to do. your problem is that it isn't passing the privs to allow you to read or write.

  • open terminal
  • sudo apt-get install pmount udisks udisks2 gvfs consolekit

next

  • open terminal
  • su root
  • cd /etc/polkit-1/localauthority/50-local.d/

make a new file called 55-myconf.pkla

edit the file and input this

[Storage Permissions]
 Identity=unix-group:storage
 Action=org.freedesktop.udisks.filesystem-mount;org.freedesktop.udisks.drive-eject;org.freedesktop.udisks.drive-detach;org.freedesktop.udisks.luks-unlock;org.freedesktop.udisks.inhibit-polling;org.freedesktop.udisks.drive-set-spindown
 ResultAny=yes
 ResultActive=yes
 ResultInactive=no

Next:

  • cd /etc/polkit-1/localauthority/50-local.d/

make a new file called 10-udisks.pkla

input this into the file

[Local Users]
 Identity=unix-group:users
 Action=org.freedesktop.udisks.*
 ResultAny=yes
 ResultInactive=yes
 ResultActive=yes

[Local Users]
 Identity=unix-group:users
 Action=org.freedesktop.udisks2.*
 ResultAny=yes
 ResultInactive=yes
 ResultActive=yes

Now please make sure you are in the storage group, if you are not sure try:

do this as yourself not root

sudo usermod -a -G storage yourusername

Good luck hope this helps, like I said its been awhile since I had to do that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.