Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this question gets asked almost every day with a different Macbook version, but I can't seem to find anything definitive for a Summer '09 MBP (5,5).

I installed Ubuntu 12.10 and wifi won't work. I am VERY new to Ubuntu, so I need some guidance as to HOW to troubleshoot this.

On a side note, I have followed several other guides and I have verified that there are some Broadcom drivers installed, but I'm not sure if they are the right ones.

So, I suppose my two questions are as follows:

1) What steps would you take to begin resolving this issue of missing wireless

2) Is it possible that, if I installed xUbuntu (I like its GUI more), I wouldn't have this same issue?

Thank you, in advance, Wes


My wireless adapter is:

BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)

share|improve this question
1  
Can you post the output of lspci so we can figure out what Broadcom you have? –  Seth Jan 14 '13 at 15:44
    
OK. unfortunately, I am at work now and left that laptop at home. I will run this tonight. That said, doing a search, think I have the following: Broadcom 4322AG 802.11a/b/g/draft-n Wi-Fi Adapter –  Wescrock Jan 14 '13 at 15:54
    
Looks to BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01) –  Wescrock Jan 15 '13 at 1:51
add comment

1 Answer

up vote 2 down vote accepted

I was able to solve my issue, once knowing my broadcom model.

Here is a link.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.