Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

My system language is German but my text in libreoffice writer gets all underlined because the spell chechking language is set to English USA. Neither can I change it to German there which is also listed nor can I change it via Extras --> Language --> All text.

I've found this:

I deleted two folders named "bundled" and restarted libreoffice but the problem persists. No new folders called bundled created by the way.

I've also installed a German dictionary via extensions which didn't help.

I'm on 12.04, system is up to date.

share|improve this question

1 Answer 1

  1. Use Synaptic, apt-get or any other package manager to install the package hunspell-de-de Install hunspell-de-de.

    This is the spell check package for German that LibreOffice uses.

  2. From the LO Writer menu, select Tools > Options

  3. In the dialog, choose Language Settings > Languages

  4. You can change your interface and locale languages to German if they are not already set, but the important one is: Default languages for documents (Western). Make sure this says German and hit OK.

  5. Restart LO Writer.

That's it. New documents should default to German and use the German spell check.

Note that old documents will still be set to English. To change an existing document to German, from the menu: Tools > Language > For All Text > Reset to Default Language

share|improve this answer
I have a similar problem, but my language is already installed. In every text field I begin typing (not only LibreOffice), I need to change it back to my own language, or just disable it at all (it's one click faster, plus I don't have to select all the text). Please, how can I just change the default language? –  Rodrigo Jun 12 at 3:29
@Rodrigo If you're using ibus, there's a setting to use the same input method in all windows (which is default) or to allow differnt im's in different windows. But you should ask a new question rather than using the comments. ;) –  chaskes Jun 12 at 12:25
Thank you, @chaskes. –  Rodrigo Jun 12 at 12:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.