Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know how to tether via USB using Android to my Ubuntu 10.04 and this How to Tether Android Smartphone to Ubuntu Linux how-to is what I have been doing for the last couple of months (running fine).

The issue now is that the "Wired connection" appearing does not appear anymore and it seems that the static IP assigned to my other interface (eth0) are being assigned to it somehow. These settings are obviously not suitable in tethering and therefore my tethered connection isn't working.

This behaviour changed for me recently, and I seem unable to figure out why.

On my other PC (same OS) I do see another "Wired connection" and tethering works fine on that one.

How to troubleshoot and fix this?

Before tethering:

abc@xyz:~/Downloads$ ifconfig eth0      Link encap:Ethernet  HWaddr
e8:03:9a:65:08:7e  
          inet addr:117.129.59.85  Bcast:117.129.59.255  Mask:255.255.255.0
          inet6 addr: fe80::ea03:9aff:fe65:87e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15420730 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3969133 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4037041565 (4.0 GB)  TX bytes:1397544101 (1.3 GB)
          Interrupt:43 Base address:0x6000 

ham0      Link encap:Ethernet  HWaddr 7a:79:00:00:00:00  
          inet6 addr: fe80::7879:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1404  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:110235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:110235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:235513662 (235.5 MB)  TX bytes:235513662 (235.5 MB)

vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
          inet addr:192.168.56.1  Bcast:192.168.56.255  Mask:255.255.255.0
          inet6 addr: fe80::800:27ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:618 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:128782 (128.7 KB)

After tethering (note the eth0 and usb0 entries):

abc@xyz:~/Downloads$ ifconfig

eth0      Link encap:Ethernet  HWaddr e8:03:9a:65:08:7e  
          inet addr:117.129.59.85  Bcast:117.129.59.255  Mask:255.255.255.0
          inet6 addr: fe80::ea03:9aff:fe65:87e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15423208 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3970469 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4037536312 (4.0 GB)  TX bytes:1398652503 (1.3 GB)
          Interrupt:43 Base address:0x6000** 

ham0      Link encap:Ethernet  HWaddr 7a:79:00:00:00:00  
          inet6 addr: fe80::7879:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1404  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:110235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:110235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:235513662 (235.5 MB)  TX bytes:235513662 (235.5 MB)

usb0      Link encap:Ethernet  HWaddr 82:43:72:0b:d0:6f  
          inet addr:117.129.59.85  Bcast:117.129.59.255  Mask:255.255.255.0
          inet6 addr: fe80::8043:72ff:fe0b:d06f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:196 (196.0 B)  TX bytes:5552 (5.5 KB)**

vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
          inet addr:192.168.56.1  Bcast:192.168.56.255  Mask:255.255.255.0
          inet6 addr: fe80::800:27ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:618 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:128782 (128.7 KB)
share|improve this question

2 Answers 2

Take a further look in the settings for your "Wired Connection" in which you assigned the static IP in for eth0. In the first tab, you've probably removed the MAC address there. Once there's no MAC address filled in, the connection settings can apply to all interfaces. Restore your MAC address there:

enter image description here

For newer releases of Ubuntu the option "Restrict To Interface" applies in a similar manner. Users running into the same issue in newer releases, want to have it on eth0 only.

Below is a screenshot of the NetworkManager in 12.04 in KDE, but this should be very similar in GNOME.

enter image description here

share|improve this answer
    
Hello.. i dont have any such option in my network manager.. see here:imageshack.us/photo/my-images/152/screenshoteditingwiredc.png .. i can install a different network manager if u suggest, to fix this.. –  ashishsony Jan 15 '13 at 5:17
    
@ashishsony I've updated my answer for 10.04. You were right about it - the option is not there, but the MAC address is doing the same thing. –  gertvdijk Jan 15 '13 at 9:06

I found the solution.

There is an option to select "Available to all users".. this was checked.. after unchecking it.. the tethering was detected correctly as usb0 connection..

I think this seems to be a bug in ubuntu network manager as surely "Available to all users" does not in any way mean "use same properties for all wired connections either from different ports!" :)

img

share|improve this answer
    
The "Available to all users" might have a side effect, but this was not your issue. See my update answer. –  gertvdijk Jan 15 '13 at 9:07
    
@gertvdijk dont get confused due to the image i posted.. i said.. when available to all users was checked it was not working.. when i unchecked it started working. try it on 10.10 this seems to be a bug. maybe ill try it on latest 12.10 on my other machine. and confirm on this if its related to 10.10 or still persisting in recent versions too. –  ashishsony Jan 16 '13 at 8:02
    
I think I understood you correctly. The "Available to all users" is not a setting which can cause this, but could have a side effect (either ticked or unticked) which solves your issue. The assignment to an interface you didn't want it to assigned to is really the MAC address setting. –  gertvdijk Jan 16 '13 at 8:05
    
@gertvdijk i forgot to mention that i did not assign any mac address in the network manager .. that field is absolutely empty.. the only manual settings i did were related to the ip settings shown in my image... –  ashishsony Jan 16 '13 at 10:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.