Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this two-monitor configuration that works flawlessly in the default 12.10 GNOME wm. This is my xorg.conf:

Section "Monitor"
    Identifier "VGA0"
    Option "Enable" "true"
    Modeline "1920x1200_60.00"  193.16  1920 2048 2256 2592  1200 1201 1204 1242  -HSync +Vsync
    Option "PreferredMode" "1920x1200_60.00"
EndSection

Section "Monitor"
    Identifier "LVDS0"
    Option "Enable" "true"
    Modeline "1368x768_60.00"  85.86  1368 1440 1584 1800  768 769 772 795  -HSync +Vsync
    Option "PrefferedMode" "1368x768_60.00"
EndSection

Section "Device"
    Identifier "Radeon0"
    Driver "radeon"
    Screen 0
EndSection

Section "Device"
    Identifier "Radeon1"
    Driver "radeon"
    Screen 1
EndSection

Section "Screen"
    Identifier "Big Screen"
    Device "Radeon0"
    Monitor "VGA0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1920x1200"
    EndSubSection
EndSection

Section "Screen"
    Identifier "Little Screen"
    Device "Radeon1"
    Monitor "LVDS0"
    DefaultDepth 24
    SubSection "Display"
        Depth 24
        Modes "1368x768"
    EndSubSection
EndSection

Section "ServerLayout"
        Identifier "My Layout"
        Screen 0 "Big Screen"
        Screen 1 "Little Screen" RightOf "Big Screen"
        Option "Xinerama" "true"
EndSection

However, awesome wm that I am trying to set up right now is simply mirroring upper left part of the bigger screen to the smaller screen. Although I am happy that the resolution is right, I would obviously like to fill each screen with different content.

What am I doing wrong?

share|improve this question
add comment

2 Answers

i should be able to help. it's very similar to the setup i'm using. I think your problem is caused by Xinerama being on really. i suggest using the amdcccle program to configure it. You could also use lxrandr, it's very simple to use, but without installing anything else, use "gksudo amdcccle", expand the Display Manager group, and click on Xinerama. make sure there is no check there. It may be grey. if it's grey, select Display Manager, click the down arrow in the upper right corner of the icon representing monitor 2, and select "Multi-display" and then "multi-display desktop with displays 1". go back and make sure there's no check in Xinerama.

share|improve this answer
    
Thanks for the answer! Unfortunately, this (I mean, installing and attempting to run amdcccle ending by an error in the command line) screwed up my system hard -- I was unable to go into graphic mode. I guess I should have been more careful -- obviously, my graphic card is either too old or I am not using the proper driver for this kind of stuff. I do not want to digg into this as I really hate low level administration of my system. :-) So I rollbacked to the previous stable state and I won't be using the smaller monitor. –  lukasLansky Jan 22 '13 at 14:25
    
I'm sorry that caused more problems and didnt fix anything. I realize you've kind of "moved on", but I'll post another possible solution. maybe it'll work without changing drivers. –  Joshua Kersey Jan 22 '13 at 17:06
add comment

if you wanted to try another easy/reversible option, you could make a copy of your xorg.conf, and then change "true" to "off" for xinerama.

these commands should do it:

cp /etc/X11/xorg.conf ~/xorg.conf
cat ~/xorg.conf | sed 's/true/off/g' > ~/xorg.conf.new
sudo cp ~/xorg.conf.new /etc/X11/xorg.conf

if something goes wrong, you can copy the original back using recovery mode and this command (edit user to be YOUR username of course)

sudo cp /home/user/xorg.conf /etc/X11/xorg.conf

the advantages of being able to use the second display are worth the effort and time to get it to work, in my opinion.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.