Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am PXE booting some Ubuntu machines in a cluster. All of a sudden my rc.local script has stopped working.

I've check the permission of /etc/rc.local:

-rwxr-xr-x 1 root root 1087 Jan 14 11:04 /etc/rc.local

I've checked that rc.local is symlinked in the following folders:

/etc/rc2.d 
/etc/rc3.d
/etc/rc4.d 
/etc/rc5.d

They all symlink to /etc/init.d/rc.local.

I've tried to output echo lines from the script to /tmp/test.out but no luck. When I execute the rc.local script after the machines has booted, it works fine.

What can cause rc.local not to run?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I finally got it working. Dunno if this is the best solution, but works for now. I moved the /etc/init.d/rc.local and the /etc/rc.local to a different location, and the I ran

update-rc.d rc.local remove

Afterwards I moved the two scripts back into place and ran

update-rc.d rc.local defaults

It now appears to be working correct.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.