Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I opened System monitor to kill an app and found three enigmatic entries labelled pxgsettings and four sh entries. See image below: System monitor

Does anyone have a clue what these are?

EDIT

Today (2 days later) I see there is one more pxgsettings entry and one more sh entry.

In System Log I found this line:

dbus[896]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.57" (uid=1000 pid=2013 comm="bluetooth-applet ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.2" (uid=0 pid=919 comm="/usr/sbin/bluetoothd ")

But my bluetooth is disabled and I never tried to send anything through bluetooth.

Is this a bug? Has my computer been compromised?

This is the output of top: Top output

Now that I'm using Ubuntu raring the new version of System monitor gives more clues. See the following screenshots: System monitor 13.04 System monitor 13.04 2

So it seems these processes are unity related. Should I worry?

share|improve this question
    
Is this an issue for you still? I have the same issue but I don't have a bluetooth enabled laptop. –  Nil May 6 '13 at 4:39
    
The issue remains even now on 13.04. –  To Do May 10 '13 at 15:31
    
I take it you're running Gnome 3 based on the information provided by the libproxy1-plugin-gsettings package. Here is a link with more information: pxgsettings info Basically this tells us it has something to do with a web enabled program. Are you using something like the calender maybe to synch with google? Can you check gnome-session-properties aka startup applications and see if anything like tomboy/calender is enabled there? What is the output of top? –  l300lvl May 11 '13 at 4:57
    
I'm not using calendar but I'm using Empathy with a few online accounts. –  To Do May 13 '13 at 7:15
    
I added the output of top. Well, a screenshot of it (it keeps changing). –  To Do May 13 '13 at 7:22
show 6 more comments

3 Answers

Direct Short(er) Answer

Is this a bug?
Probably, the DBUS error is nothing, the hanging pxgsettings is either bad config or poorly written interface in some program that runs (and reads settings) frequently. If you can try down the cause you should submit a bug report.

Has my computer been compromised?
Almost certainly not. Again the DBUS error is not ever really an error. It is technically a bug but not one that would effect anything. The hanging processes is likely a bug.

More Info

If someone did compromise your system the information they could get from pxgsettings would be rather pointless. I suppose there could be sensitive data there, but mostly it would be window positions, label names, color choices, etc. Nothing like passwords should be stored there. To rule out "compromise" you can always run users and see if there's more then just you running the system. If there is someone else on your system it will show there. You can also check top for ssh sessions or high running CPU/MEM programs that you didn't launch. Finally /var/log/auth.log will show all login attempts and successes (with some other data) if you still want to dawn your tin foil hat. But truthfully all that is a bit overboard.

Links
This may help. Basically pxgsettings is "A helper binary to query gsettings".

It would appear that you have something quarring gsettings and crashing. GSettings is a High-level API for application settings. In short it looks like there is a process running every one in a while that hangs reading some settings from something. Unfortunately you don't have enough info to track down the process. It could be related to the program your trying to kill.

I do not think it's related to Bluetooth. That Bluetooth message is normal. The Rejected message is from DBUS and not Bluetooth. In fact that error has almost nothing to do with Bluetooth.

share|improve this answer
    
The hanging pxgsettings could be a DBUS error I suppose. But that's a really bad stab in the dark. –  coteyr May 12 '13 at 22:57
    
I don't know if To Do is going to respond, but in my particular case I'm running the Unity-desktop and not Gnome 3. I'd like to show you a list of processes to see if we could narrow it down, but this is not my question. If To do responds and says he found the answer, I'll award you the bounty (if it expires I'll add it on again). –  Nil May 13 '13 at 1:21
    
Running users show my username twice. –  To Do May 13 '13 at 7:14
    
That is normal. –  coteyr May 13 '13 at 10:30
    
I'm just going to go ahead and award the bounty given how much progress this has made. +1 also. –  Nil May 13 '13 at 18:32
add comment

Do you use Tomboy?

It appears to leave five zombie pxgsettings processes around every time a synchronization is done. It may not be relevant but my machine is behind a proxy.

Killing tomboy cleaned up all the pxgsettings instances.

share|improve this answer
    
No I do not use Tomboy. –  To Do Jan 17 '13 at 16:18
add comment

I am also tracking down why my system has 5 pxgsettings processes (each one spawned from a lingering 'sh' process) upon startup, and they seem to grow somewhat from there. This is Ubuntu 13.04. In 'pstree':

 |-gvfsd-http-+-sh---pxgsettings---2*[{pxgsettings}]
 |            `-3*[{gvfsd-http}]

 |-unity-lens-phot-+-sh---pxgsettings---2*[{pxgsettings}]
 |                 `-3*[{unity-lens-phot}]
 |-unity-scope-gdr-+-sh---pxgsettings---2*[{pxgsettings}]
 |                 `-3*[{unity-scope-gdr}]
 |-unity-scope-vid-+-sh---pxgsettings---2*[{pxgsettings}]
 |                 `-2*[{unity-scope-vid}]
 |-unity-shopping--+-sh---pxgsettings---2*[{pxgsettings}]
 |                 `-2*[{unity-shopping-}]

They all bear the stamp of org.gnome.system.proxy in the full command. Here I pasted one full command through strace and it produces normal output and completes normally.

[Linux2:~]$ strace /usr/lib/x86_64-linux-gnu/libproxy/0.4.7/pxgsettings org.gnome.system.proxy org.gnome.system.proxy.http org.gnome.system.proxy.https org.gnome.system.proxy.ftp org.gnome.system.proxy.socks

So I don't know why those pxgsettings processes linger. It does look like a bug, to me.

I have already gone through System Settings > Network > Network Proxy which was already set to "None", but I hit "Apply System-Wide" anyway and rebooted, to no avail. Maybe I will try "Manual" and leave the settings black. I have no proxy to use for any application.

P.S. My real issue is a low number of X11 apps/windows allowed to open. I have started doing killall pxgsettings which is really killing the unity-lens-junk processes which frees up X resources, and I can keep operating my system, as kind of a side effect. There's also some X localhost socket limit set too low, or something. Onward.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.