Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to connect my broadband connection with Ubuntu. The connection works fine when I use Windows 7. However, when I use ubuntu I am not able to access the internet.

I followed all the steps mentioned in various sites and still could not find a solution. I have installed Ubuntu 8.04 Hardy Heron on my system. The interface eth0 is not at all detected and when I go to System->Administrator->Network in the menu I do not getting an option for wired connection. Only the Wireless connection and Point to Point connection tabs are available.

share|improve this question

closed as off-topic by Richard, Braiam, Eric Carvalho, Avinash Raj, wojox Mar 6 at 14:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Hi user, I would highly recommend downloading Ubuntu 10.04 and not using Ubuntu 8.04, the support for 8.04 only lasts for another few months. –  Martin Owens -doctormo- Feb 1 '11 at 13:15
    
On windows 7 how do you connect? Is it by dialing (by clicking on BSNL Broadband icon) or is it a direct connection, where, if you just turn on the modem it gets connected? –  nixnotwin Feb 2 '11 at 1:47

5 Answers 5

As Martin says, you need to install a newer version of Ubuntu. Mobile Internet support has become more mature in recent versions of Ubuntu, with the work carried out in the NetworkManager package.

Read, for example, the discussion, at http://www.crazyengineers.com/forum/general-help/37747-how-setup-bsnl-3g-data-card-ubuntu-10-10-guide.html

(Once you get Ubuntu 10.10) The typical information that is missing to configure mobile internet is the APN. From what I see about BSNL/India, the information is already in (the newer version of) Ubuntu, see http://git.gnome.org/browse/mobile-broadband-provider-info/tree/serviceproviders.xml

So, try to get a newer version of Ubuntu.

share|improve this answer
    
He has not mentioned that its "mobile" broadband, and he has mentioned eth0, which, by default, is assigned to ethernet. So he must be having trouble with setting up wired broadband. –  nixnotwin Feb 2 '11 at 1:42
    
BSNL is a mobile phone company in India. Let's have the OP clarify. –  user4124 Feb 2 '11 at 2:05
    
BSNL is the state owned telecom provider in India, it provides both landline and mobile services. Usually BSNL broadband is associated with fixed-line services. –  Ubuntuser May 4 '11 at 11:24

If you have wired modem connection, then you can follow these steps to connect to internet. Open terminal and type sudo pppoeconf. It will ask for your password. After entering password, a blue screen will appear. The following steps are to be followed : 1. Confirm that your Ethernet card is detected. 2. Enter your username(provided by your ISP). 3. Enter your password(provided by your ISP). 4. If you already have a PPPoE Connection configured, you will be asked if it may be modified. 5. Popular options: you are asked if you want the 'noauth' and 'defaultroute' options and to remove 'nodetach' - choose "Yes". 6. Use peer DNS - choose "Yes". 7. Limited MSS problem - choose "Yes". 8. When you are asked if you want to connect at start up, you will probably want to say yes. 9. Finally you are asked if you want to establish the connection immediately.

Once you have finished these steps, your connection should be working. Open the terminal again and type : sudo pon dsl-provider (to connect successfully to internet) . To disconnect you should type: sudo poff dsl-provider

share|improve this answer
    
I haveb been struggling for more than 2days. atlast solved. Thankyou verymuch :) –  suhail Mar 21 at 3:15

it very easy to connect bsnl broadband with ubuntu. There is nothing to configure. Ubuntu can detect broadband automatically in most cases. However some may feel difficulties because their modem is in pppoe mode so they requires a dialer software(pppoe dialer) for connecting to Internet. It's hard to get a suitable pppoe dialer in Ubuntu. So, for connecting BSNL broadband, change your modem configuration as multiuser type(in bridge mode). http://www.beubuntu.co.cc/2010/03/connect-bsnl-broadband-in-ubuntu-hai.html#comments

share|improve this answer

I am assuming that you are using the broadband via landline. In that case, please try to enable the multiuser mode (as has been mentioned above by Giri Murali) and then try to connect. Also if possible please try upgrading to 10.10.

share|improve this answer

My first question, can you provide your ethernet card manufacturer from Windows 7?

It is very much possible that your ethernet is not detected because the driver required for detection is a non-free driver. Click on System -> Preferences -> Add Hardware Drivers. If the non-free driver is indeed required, Ubuntu will show you what driver is required from that program. Then you can download that .deb file from Windows and install in UBuntu.

Hope this helps!

Also, as others have suggested please update to the latest LTS version, which is 10.04.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.