Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a Dutch user and prefer the my local date & time format, system wide. I have no trouble speaking or understanding English and find it very useful to have the rest of my system configured in English to make my life easier when I need to Google a term, for example.

Is it possible to apply the a local date/time/currency/etc. format to the system, while maintaining English menu & dialog captions?

share|improve this question
add comment

3 Answers 3

up vote 8 down vote accepted

Abolutely,

  • go to System → Administration → Language Support

  • at Language, select English as your default language:

    enter image description here

  • And in the Text tab, choose Dutch as your preffered Locale for numbers, dates and currency.

    enter image description here

I've been using this setting for a long time, and it's a bit weird sometimes, you may see something like "This file was modified on Maandag...", but it works very well with most apps.

After a bit of troubleshooting, it turns out you also have to:

  • Click 'Apply System-Wide'

  • Reboot

share|improve this answer
    
It's System->Administration->Language Support in my system. –  Javier Rivera Feb 1 '11 at 13:10
    
@Javier Oops :) Thanks for the correction. –  Stefano Palazzo Feb 1 '11 at 13:12
    
Thanks for the reply. I actually did this and expected it to work, but my settings are still set to English for some reason. I tried applying system-wide and rebooting, without success. –  Aron Rotteveel Feb 1 '11 at 13:19
    
Please post the output of locale to a pastebin and add it to your question, I just noticed mine is a bit strange. –  Stefano Palazzo Feb 1 '11 at 13:22
    
@Stefano you have selected German, not Dutch. At least in the screen-shot and according to the pastebin. Dutch would be nl_NL. –  Pit Feb 1 '11 at 14:06
show 6 more comments

For some reason it seems to work now.

What I did:

  • Click 'Apply System-Wide'
  • Reboot

I'd swear I did this before, but logic is against me.

share|improve this answer
    
I'm glad that did it! I've added those two steps to my answer so that it now explains the whole thing. –  Stefano Palazzo Feb 1 '11 at 18:17
1  
Guys I already commented on the first answer that you have to restart you system (several times) for "Changes to take effect". There is even a notice under the language-drop-down menu saying "Changes take effect the next time you log in" –  Pit Feb 1 '11 at 18:35
add comment

For Ubuntu 11.10

  • Go to System setings → Language Support
  • At Language, select English as your default language
  • Click Install/ remove languages...
  • Make sure the language you want for your date, time and currency is installed
  • Go to the Regional formats tab to select your preferred locale for time, date and currency
  • Ignore the error in the example
  • Click Apply system-wide and reboot
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.