Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to disable the wifi on boot? I'm using network-manager to manage the wifi connection and when I disable this, setting is temporary to the current session. Exists therefore a method to make persistent settings for network-manager? thanks

share|improve this question
    
Duplicate?: askubuntu.com/questions/24171/… –  Mussnoon Feb 1 '11 at 11:56
    
@Mussnoon My question is specific to network-manager, who in an older version of ubuntu kept the settings at boot, not now. And because it's a widespread problem in other forums, wondering if anyone knows why ... –  BonboBingo Feb 1 '11 at 12:25
    
You can also edit /etc/network/interfaces and remove the wlan0, wlan1 ... –  begueradj Jul 1 at 15:28

1 Answer 1

up vote 3 down vote accepted

It sounds like you want to right click on the network manager applet and select disable wireless, if this isn't being saved over your session then please report it as a bug:

https://help.ubuntu.com/community/ReportingBugs

If on the other hand you want to prevent your computer from automatically joining networks, then you must go into the network editing and either remove and uncheck the use automatically option for each network.

If you want to save power, then please use the advice in the guide mentioned by Mussnoon above, shutting off with rfkill will be most effective:

How can I keep a wireless card's radio powered off by default?

By running sudo nano /etc/rc.local add this:

rfkill block wifi

before the line exit 0

share|improve this answer
    
Then I will report the bug... –  BonboBingo Feb 1 '11 at 18:49
    
On my Ubuntu 14.04 the on-off-state survives a reboot just fine –  rubo77 Jul 1 at 15:15
    
It seems like the rfkill in rc.local only works if you add a sleep before: /bin/sleep 10 && rfkill block wifi (see Turn off the Wireless card on each boot ) –  rubo77 Jul 1 at 19:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.