Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just joined the Ubuntu Unity developers Bazaar repository and am eager to get started on hacking the code! Do I need to run Natty to be able to do this? Or can I simply use Maverick? I'd prefer to be able to work on Maverick because it is stable.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If you're developing a Unity Place then you can do that one either 10.10 or 11.04.

However for most Unity development you need to be on 11.04 as it's changed significantly from 10.10. You can either do that with virtualization or creating a separate USB stick.

We have set aside a bunch of "bitesize" bugs for people to get started hacking on Unity, and we'll probably have some IRC tutorial sessions too:

share|improve this answer
    
Thank you. I've got a problem installing 11.04a1 as its own partition on my computer, though. It always starts the installation, then freezes and doesn't do anything. I press Ctrl-Alt-F1, type ls and get the message Too many files open on system. Can you help me? –  Nathan Moos Feb 3 '11 at 23:39
    
@Nathan Probably best to wait until it's more baked, closer to beta. –  Jorge Castro Feb 3 '11 at 23:57
    
Is 11.04a2 easier to install? Does the installer actually work? –  Nathan Moos Feb 4 '11 at 0:05
    
Depends on your hardware really - best thing to do is give the LiveCD a shot or use virtualization. –  Jorge Castro Feb 4 '11 at 13:50
    
It seems as though I can develop Unity 2D on Maverick, though. –  Nathan Moos Feb 8 '11 at 2:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.