Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Dell mini with 10.10 netbook edition, I have run into a problem where firefox covers the whole screen and there is no way to get to any other windows except by minimizing. Alt+Space does not allow me to move or resize. Rebooting did not help. I ended up removing the .mozilla directory which solved it, but lost all my settings. In case it matters, I'm using 2 monitors. Any info on this?

share|improve this question
    
Try running firefox in safe mode (firefox -safe-mode) with your old profile if you haven't irrevocably removed it. There might be a conflicting addon or preferences. –  user6658 Feb 1 '11 at 2:13
    
Have any of the answers solved your problem? –  djeikyb Feb 8 '11 at 5:35
    
@djeikyb, I haven't run into it again –  SpashHit Feb 10 '11 at 12:41
add comment

2 Answers 2

One thing you can do with any window that has important bits below or above the screen edge is hold down alt while click and dragging with your left mouse button. It will let you drag the window around wherever you need. You can also resize by holding down alt while click and dragging with your right mouse button.

I suspect that you'll be fine once you resize Firefox down to something reasonable. After that, feel free to maximize the window or resize normally.

share|improve this answer
add comment

It may be possible that you previously went into full-screen mode (F11), and then exited from Firefox.

There appears to have been a bug, where the full-screen size is remembered by Firefox, but not not that it was in full-screen mode.

share|improve this answer
    
Would that survive closing the app (and even rebooting)? –  SpashHit Feb 2 '11 at 2:52
    
@SpashHit I wouldn't have thought so, but it does describe the other symptoms. Maybe Firefox saves FullScreen mode setting, for kiosk usage? Unless you saved your old profile, we're not really going to be able to get to the bottom of the problem anyway. –  Douglas Leeder Feb 2 '11 at 8:52
    
Interesting - I just tried quiting (Ctrl-Q) from a FullScreen Firefox session. It didn't remember fullscreen mode, but it did remember that size - so it appeared as a normal window (memu etc weren't on auto-hide), but all the window chrome and Gnome system bars were covered. –  Douglas Leeder Feb 2 '11 at 8:55
    
There might be a bug there even if it wasn't your problem. –  Douglas Leeder Feb 2 '11 at 8:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.