Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried searching for answers but can't find any. I'm running Ubuntu 10.04 LTS and have emacs22 installed:

ii emacs22 22.2-0ubuntu9 The GNU Emacs editor (Emacs 22) ii emacs22-bin-common 22.2-0ubuntu9 The GNU Emacs editor's shared, architecture dependent file ii emacs22-common 22.2-0ubuntu9 The GNU Emacs editor's common infrastructure ii emacsen-common 1.4.19ubuntu1 Common facilities for all emacsen

I find that I cannot resize the outer frame (X window) of the emacs session. When I move the mouse to the corner of the window, it doesn't change into the resize icon.... help!

share|improve this question
    
Just to check that you're launching the x-windows version, rather that the terminal version, what does it say it you type: "ctrl-H V window-system"? Look at "Its value is ...". –  Dave Jennings Jan 31 '11 at 22:15
    
window-system is a variable defined in `C source code'. Its value is x –  user9987 Jan 31 '11 at 22:22
    
I can't reproduce because emacs23 with 10.10 works fine -- do any of these work-arounds (such as using Alt-F8) work for you? askubuntu.com/questions/4109/increase-resize-margin-on-windows –  belacq Jan 31 '11 at 22:40
    
Not sure, but as a long-shot, what is: "ctrl-h v window-size-fixed"? It should be "nil". If you are not even getting a mouse-pointer change it sounds like X rather than emacs. You wouldn't possibly have something set in .Xdefaults would you? –  Dave Jennings Jan 31 '11 at 22:43
    
Thanks, Alt-F8 allows me to change the width of the window at least. –  user9987 Jan 31 '11 at 22:55

2 Answers 2

You can set the emacs window geometry at startup ->

On you panel emacs icon or through the menu editor - set the command to run emacs like this -- emacs -geometry 135x42

See HERE for other ways to do it!

Enjoy your bigger window!

share|improve this answer

You can set a shortcut (e.g., Super-middlemouse) to resize windows. Go to CompizConfig Settings Manager (or install it if you haven't) and open "Resize window".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.