Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a system booting over the network with PXE on 11.10. I upgrade to 12.04 and now the boot fails during startup with the following messsage:

Gave up waiting for root device. Common problems:

-Boot args (cat /proc/cmdline)
-Check rootdelay= (did the system wait long enough?)
-Check root= (did the system wait for the right device?)
-Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/nfs does not exist. Dropping to a shell!

My PXE config file is:

default linux

say Starting Legolas

LABEL linux
KERNEL legolas/vmlinuz
APPEND netboot=nfs root=/dev/nfs initrd=legolas/initrd.img nfsroot=192.168.0.8:/srv/tftp/legolas,rsize=4096,wsize=4096 ip=dhcp pci=nomsi rw quiet

Any ideas why this does not work on 12.04? Thanks.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Correcting the pxeconfig line enabled the system:

APPEND boot=nfs root=/dev/nfs initrd=legolas/initrd.img nfsroot=192.168.0.8:/srv/tftp/legolas,rsize=4096,wsize=4096 ip=dhcp pci=nomsi rw quiet

The change from above was only boot=nfs

I also want to point out that DisklessUbuntuHowto does not mention the boot=nfs parameter, and I could not get the system to boot without it. I hope someone with the same issues finds this before they waste too much time.

share|improve this answer
    
Are you sure this was the issue? I'm booting 12.04 from PXE fine without boot=nfs. My line: APPEND root=/dev/nfs nfsroot=1.2.3.4:/path/to/ubu1204 initrd=ubuntu/12.04/initrd.img-3.5.0-19-generic ip=dhcp rw -- (removed hardware specific workarounds unrelated to PXE). Maybe the unneeded (or even wrong?) netboot parameter was causing it instead. –  gertvdijk Jan 16 '13 at 16:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.