Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem with internet in terminal, ubuntu 12.10. I try to download a file by axel but i got an error:

HTTP/1.1 504 Connect to [URL]:80 failed: Connection refused

It's happen after I remove tor, how can i fix this?

share|improve this question
    
I know have to change configure of something but i don't know where and how is it? –  hertkof Jan 14 '13 at 7:00

1 Answer 1

up vote 0 down vote accepted

Axel has a configuration file. This sits either in $HOME/.axelrc or in /etc/axelrc. In this file the proxy is configured. Look for a line starting with http_proxy. The line probably reads http_proxy = http://127.0.0.1:8118. Remove it or place a # in front of the line. Now axel 'forgets' about the proxy and uses a direct connection.

If you find no such setting there might also be a shell variable called http_proxy. Just open a terminal and type echo $http_proxy. If you see a valid proxy, axel will also try to use it. Just unset the variable and axel will also use a direct connection.

share|improve this answer
    
thanks it worked. –  hertkof Jan 31 '13 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.