Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently purchased a Novatech nFinity N1410 laptop and am having problems with the wireless, which

sudo lshw -C network 

tells me is Centrino Wireless-N 2230 and using the iwlwifi driver.

The problem is that after the device has been suspended, I am not able to get the wireless working again without a restart. The network indicator states that the wireless disabled by hardware switch.

Though Fn+F2 is meant to be the wireless switch,

xev 

tells me that the system doesn't see it as anything at all when I press this hardware combination. Also, though the brightness up/down buttons work fine, the volume up/down buttons do not work either.

What can I do to fix this? I am running Ubuntu 12.10 with all available updates installed.

share|improve this question
    
Are you sure you haven't bumped a switch anywhere on the outside of your laptop? I've done that on more than one occasion. –  DaimyoKirby Jan 14 '13 at 0:16
    
@DaimyoKirby The hardware Fn button is Fn + F2, however this does not do anything at all. Also, after a restart, the wireless starts working again. –  fahadayaz Jan 14 '13 at 16:30
add comment

4 Answers

Try this solution

You can use this command to unblock all wireless devices: From the terminal,

sudo rfkill unblock all

You can also run

rfkill list all 

to find out whether it is a software block or rather a hardware block

You may have to reinstall the driver

sudo modprobe iwlwifi

If wireless begins working again, you can create scripts in /etc/pm to do this each time you suspend and resume.

gksudo gedit /etc/pm/config.d/modules

...and added the line...

SUSPEND_MODULES="iwlwifi"
share|improve this answer
    
Unfortunately, this does not work. rfkill says that my wireless is hard blocked. However, my hardware switch, Fn + F2 doesn't register as doing anything at all. The wireless is fixed after a reboot. –  fahadayaz Jan 14 '13 at 16:26
add comment

I've been looking into buying one of these and have been looking for potential problems, looks like your solution can be found in the novatech forums:

  1. Simply created a new file called: brcm.sh
  2. Inserted the below code and save:

```` Code:

#!/bin/bash
# Simple bash script to fix resume from suspend issues...
# Place this script in /etc/pm/sleep.d/
# then chmod +x /etc/pm/sleep.d/brcm.sh

case $1 in
hibernate)
/sbin/modprobe -r brcm80211
;;
suspend)
/sbin/modprobe -r brcm80211
;;
resume)
/sbin/modprobe brcm80211
;;
thaw)
/sbin/modprobe brcm80211
;;
esac
  1. Placed it in the following location: /etc/pm/sleep.d/

  2. Made it executable: sudo chmod +x /etc/pm/sleep.d/brcm.sh

Source: http://forum.novatech.co.uk/showthread.php?25709-nFinity-N1411-solved-Ubuntu-12-10-install-and-wifi-wake-from-suspend&p=331411

share|improve this answer
add comment

i had the same problem and i have no hardware switch just F2 for disabling and enabling wifi instead of using unblock wifi try blocking it using

$ sudo rfkill block wifi 

i know it sounds crazy but it worked for me and i'm using a dell laptop and we have the same wifi driver after using unblock

1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

after using block

1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: no

and to remove the soft block just click on the wifi button on the top right corner of your unity desktop and select Enable Wi-Fi

share|improve this answer
add comment

For my dell D630 notebook, the following has worked, to solve the "Soft blocked: yes" wifi after a suspend:

sudo rmmod wl
sudo modprobe wl

After typing this the wifi has returned. No reboot required anymore, a success!

Seems re-initializing the kernel module solves the problem.

(wl, the wireless kernel module, I have a broadcom wifi, the kernel module name might differ)

You might try this at /etc/pm/sleep.d/brcm.sh when the system is returning from a suspend as noted by John White.

I have an ubuntu 12.04 64 bit.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.