Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My upgrade to 12.04 stopped during the "Installing the upgrades" section (it's showing Setting up libmythes... as the last output. It says Configuring nautilus-data under the progress bar). I can still interact with GUI but it's been on 17 minutes remaining for hours and no change. I do have access to a terminal. Is there anything I can do to safely finish the upgrade?

I tried sudo apt-get dist-upgrade and it tells me /var/lib/dpkg/lock cannot be gotten. There is no cancel button on the GUI. Nor any Window decorations (compiz hung with 100% cpu and I killed it before this happened. I thought it seemed to run fine a for a little while after this). I tried alt+c, alt+f4, ctl+w, and ctl+q to close/cancel the upgrade, but nothing worked.

share|improve this question
    
Are you upgrading through the GUI or command line? If you've already cancelled the upgrade, you can run sudo apt-get dist-upgrade on the command line –  camconn Jan 14 '13 at 2:22
    
It's through the GUI. I don't see a way to cancel. I'll try your recommendation in a minute –  Rob Mosher Jan 14 '13 at 4:06
    
This should be closed as a duplicate as I solved it following askubuntu.com/questions/169350/… –  Rob Mosher Jan 14 '13 at 12:29
    
Actually, the question is much more specific than mine, but the solution in the comments worked. Though it's marked as answered, the major details I needed where in the comments, not the answer. Plus it leaves you guessing when you've actually solved the issue. If it'd be better to leave this open as a more general "upgrade froze" rather than "grub issue during upgrade" I can add an answer. Otherwise I'll take a shot at cleaning up the other question for more general use. –  Rob Mosher Jan 14 '13 at 12:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.