Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo X220 with Intel HD 3000 on-board chip.

When I have in the Screen and Brightness Setting "save energy" option activated the screen wil lower the brightness very strongly after just few SECONDs of non-typing.

this is very unhandy. Especially if an application is running, like a video is showing in the browser.

is there no more detailed way of controlling screen brightness?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Original Answer

     I did some research and figured out how you can adjust the "idle" time of your computer. Basically this way you can adjust it so that the computer doesn't ever dim the display or adjust how long it takes before the display dims.
     You will need dconf tools, and to be on the safe side you should make sure all your packages are updated first.      So in your terminal type:

 sudo apt-get update

     Then install dconf-tools:

sudo apt-get install dconf-tools

     Once that is finished, in the terminal type the following to launch the program:

dconf-editor

     You should see an expandable list on the left hand side of this new window use them to navigate the following path:
org > gnome > settings-daemon > plugins > power
Once you've clicked power you should get a list of options on the right hand side of the window. Scrolll to find "idle-dim-battery" and uncheck the box. This will completely prevent the screen from dimming while on battery. OR if you'd prefer, find "idle-dim-time" and change the value in seconds.      Hope this helps with the dimming problem.

     Next, for video watching you can use a program called caffeine:

 sudo add-apt-repository ppa:caffeine-developers/ppa

then,

 sudo app-get update

finally:

 sudo apt-get install caffeine python-glade2


     Lastly for power saving there are a lot of different options, I personally installed and use Jupiter, Laptop mode tools, and Powertop.
     Best of luck and I hope this helps.


Workaround / Updated Answer

     Should dconf not work, you can also try adjusting these settings using the terminal command "gsettings". This accomplishes the exact same thing as Dconf editor except without the graphical user interface (GUI).
     To entirely turn off the automatic dim on battery, copy and paste the following into your terminal:

 gsettings set org.gnome.settings-daemon.plugins.power idle-dim-battery false

or to instead set a time in seconds until the computer automatically dims the screen enter the following and replace "X" with the number of seconds (i.e. 90 or 200 etc.)

 gsettings set org.gnome.settings-daemon.plugins.power idle-dim-time X

     Where, again, "X" is the number in seconds.
     I personally tried these commands in my terminal and they did work. I still highly recommend using dconf editor as above and navigating to the same power options to verify that the changes did in fact take place.

Hope this works!

share|improve this answer
    
thanks for the extensive answer. strangely i am unable to change this value or any other value there. even when being logged in or starting dconf-editor with root. any idea?? nothing just happens when right or left clicking –  Gpunkt Jan 14 '13 at 19:58
    
seems to be a known problem : bugs.launchpad.net/ubuntu/+source/d-conf/+bug/693445 –  Gpunkt Jan 14 '13 at 20:03
    
You could also try gconf editor. You can download and install it: sudo apt-get install gconf-editor This is a similar program to dconf-editor but the exact route to the options is different. I'll research it a bit and update my answer to include gconf path. –  Arammil Jan 15 '13 at 5:38
    
OKAY so apparently gconf is old (or something bare with me I'm new to Ubuntu too I just also really love nerdy research.. :D ). SO I found a workaround that you can use that SHOULD allow you to change the values without having to use dconf. I updated the above answer to reflect this. –  Arammil Jan 15 '13 at 6:15
    
thanks !!! i forgot to say that i even have a more basic problem. i cannot adjust the brightness AT ALL!! seems to run at 100% always. no matter what the setting is i try to do. the brightness bar is to the very left, but screen brightness is at 100% all other key combinations with Fn for switching on wlan etc work !! but not the ones for brightess.....i already followed suggestions with adding acpi_backlight=vendor to my grub –  Gpunkt Jan 15 '13 at 20:02
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.