Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've have an i-Sensys LBP 6020B printer and I use Kubuntu 12.10 64-bit. I've a problem with drivers for Linux 64bit because I can't find anywhere capt linux driver - PPD file for LBP6020B. What am I supposed to do? My printer doesn't print.

share|improve this question

After several months of having problems with printers, because we migrated from Windows to Linux in our company which have more than 200 computers... now we found the driver which works on all our printers. The driver is ljet4 , just found some similar model of printer with ljet4 sufix on name and it will work. I wrote more on my blog :

We didn't try on your model but every similar model we have worked very well.

share|improve this answer
I try with this drivers but it doesn't work :( I don't find my printer on the list. When I use a similar drivers from another printers it still doesn't work. – user114294 Apr 17 '13 at 13:50

Link1 Link2 Link3

I'm using Kubuntu 14.10. I tried to automatically start ccpd on startup as described in links. But it doesn't work always. So I need to run these commands before printing.

$sudo service ccpd start
$sudo service ccpd status

Following are some quotes from

1) Configuring CUPS System->Administration->Printing add printer. Choose "Add printer". Do not choose USB Printer found by Ubuntu here. Select "CAPT Printer". You should see "ccp" in URI. Change it so URI should become "ccp://var/ccpd/fifo0". Click "next", find your model and add your printer. Choose English variant if you see Japanese and English variants. Also If you do not have you exact model in list, choose nearest. For example, for LBP 810, I choose "LBP 1120".

To look for available models you may use command:

$ find /usr/share/cups/model -name 'LBPK.ppd' Close configuration dialog, open again and rename your printer to, say, "LBP6020". Remember name you chose, as later commands will refer to it.

Instead of GUI actions, you may try this:

sudo /usr/sbin/lpadmin -p LBP6020 -m CNCUPSLBP6020CAPTK.ppd -v ccp://var/ccpd/fifo0 -E Again, choose another .ppd name, if you have another printer...

2) 64-bit Systems Canon CAPT Printer Driver for 64-bit architecture include the proprietary closed-source 32-bit executable captfilter (called by pstocapt CUPS filter, used to convert PostScript data to CAPT data stream) which depends on 32-bit libraries libc6 and libpopt0. The libraries are not installed as dependencies. You can use the following commands to check whether the captfilter is working:

$ ldd /usr/bin/captfilter Messages like "not a dynamic executable" or " => not found" mean that your system affected by the problem. For a workaround install the following packages:

$ apt-get install libc6:i386 libpopt0:i386 Below is an example of working captfilter:

$ ldd /usr/bin/captfilter (0xf76eb000) => /usr/lib32/ (0xf76a6000) => /lib32/ (0xf7501000) /lib/ (0xf76ec000)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.