Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is about an older computer (Toshiba Satellite M70 that a friend wants to keep afloat) on which (beside Win XP) was installed the Xubuntu 11.10 system that would not work for some reason: now the idea would be to format/repartition the non-windows space and to install Lubuntu 12.10.

But the installation procedure stops indefinitely immediately after setting the internet connection: enter image description here after "Continue" it would just lag. Renouncing to use an internet connection has the same results.

This computer does not support USB-boot so I have to use the live cd. Gparted shows the following configuration: enter image description here

I see that the previous installation was on an extended partition. A very useful answer that I have received here said that a system should not be on an extended partition.

Is this the cause why the installation stops?

(My idea is to use a live GParted cd to format and repartition the space according to the answer above - create two primary partitions and select mount point as / and /home.)

Computer specs: http://paste.ubuntu.com/1528395/

Edit/Update: In gparted live environment was able to delete one by one the swap and the ext4 partition and afterwards the extended partition. But the same problem happened, even after trying a different cd with a different iso, Lubuntu 12.04: until in this case I have renounced connecting to the internet - see my answer

share|improve this question
1  
The other question to which you linked has a bad answer; Linux has no problems installing to logical partitions, so that's not the source of that other question's problem, nor is it the source of your problem. My guess is you've run into either a bug or bad hardware, but it's hard to say what precisely the cause is from the information presented. There's probably an installation log file in the /root directory, and it might have some clues. –  Rod Smith Jan 13 '13 at 19:12
1  
@RodSmith, I suggest you edit the answer to fix whatever is wrong rather than leave a comment as you have done. –  user25656 Jan 14 '13 at 2:40
    
@RodSmith: i would very much appreciate you doing what vasa1 suggested: that answer was useful to me - but i would very much prefer to see it corrected (although i think it is just an expression there that might be misleading. the basic idea, that i should do 2 primary partitions, one / and one /home is very good and have applied it. at that point i had never partitioned in ubuntu and didn't new the difference between "add" button to add new partition and "new partition table", and also didn't knew what mount point, primary and extended was and should be, so you see...). –  cipricus Jan 14 '13 at 10:32
add comment

4 Answers

up vote 2 down vote accepted

I am afraid, the answer you received is, strictly speaking, incorrect. An extended partition is just a container that holds logical partitions. You can't install anything on it, even if you wanted to. Primary and logical partitions are used to install OSs, so, in your case, Lubuntu can be installed either to the primary /dev/sda1 or the logical /dev/sda6, though, obviously, you'll have to let the installer format it.

PS: Can you post the hardware specs of the machine.

share|improve this answer
    
but do you know why my install stops? (i could try a new iso - even a different version of lubuntu) - or should i just use gparted cd to format and repartition? –  cipricus Jan 13 '13 at 17:30
1  
I don't know why the installation stops. It shouldn't matter what you use to format and partition, either Gparted or the *buntu installer should do the job. Check the installation CD/USB for errors, if you haven't done it yet. –  mikewhatever Jan 13 '13 at 17:34
    
specs: paste.ubuntu.com/1528395. ubuntu installer stops for unknown cause. i'll try formating with gparted because ubuntu installer cannot reach the formatting stage of the install procedure. i hope the cause why install stops will be corrected in this way –  cipricus Jan 13 '13 at 17:36
1  
1) Did you md5sum check the downloaded iso? See help.ubuntu.com/community/HowToMD5SUM Check the number against the listing in the link for your release listed at releases.ubuntu.com under the MD5SUMS link. 2) If using a CD/DVD, did you burn the disc as slowly as possible? See help.ubuntu.com/community/BurningIsoHowto 3) Did you select the media check before trying to install? help.ubuntu.com/community/Installation/CDIntegrityCheck 4) Did you ever do a "memory check" (another live-media menu choice) on your PC? Checking saves wasting time on bad media. –  ubfan1 Jan 13 '13 at 18:07
    
@ ubfan1: thnx. it focuses more and more on possible iso problem. i had burned same iso on 2 different media so ill try a new iso. it is very odd though, for i used the same iso to create persistent usb that works perfectly. odd things happen i guess –  cipricus Jan 13 '13 at 18:14
show 2 more comments

What I would try is to choose the something else option in the installer, then in gparted, I would format /dev/sda6 and set it as mount point /.

The previous attempt of installing Xubuntu might be interfering with the new installation.

This said, I suspect that the issue might by another one, but it's worth giving a try.

On other possible problem is too little RAM for the normal installer. So I would try the alternate install CD which needs less RAM.

On the other hand, if you do not want to loose Windows XP, do not touch partition /dev/sda1.

share|improve this answer
    
i cannot reach the "something else" stage: it all lags immediately after setting internet + download updates etc and pressing "continue" - it just stays there –  cipricus Jan 13 '13 at 17:50
1  
Try the alternate install CD from this site –  To Do Jan 13 '13 at 18:08
    
any idea why 12.04 desktop without internet has worked? –  cipricus Jan 13 '13 at 19:26
    
Could be a (video?) driver issue. –  To Do Jan 13 '13 at 22:22
add comment

Although you should be able to install Lubuntu on extended/logical partition, it might still be a good idea to unmount linux-swap partition, delete the extended/logical partition(s) and create instead 2 primary partitions for linux-swap and Lubuntu, and then try installation again.

However, your installation problem may also be caused by some problem in your live CD or by the fact that the computer in question does not meet the system requirements to install Lubuntu 12.10.

share|improve this answer
    
i have swaped -out or something in live cd but cannot install, the install cd cannot reach the partitioning stage. i'll try booting the gparted live cd and report, and then use another version of lubuntu. –  cipricus Jan 13 '13 at 17:47
    
Your machine seems to meet the Lubuntu 12.10 requirements though. –  Sadi Jan 13 '13 at 18:00
add comment

Trying to install from a different cd (Lubuntu 12.04 Desktop) it stopped at the same step but after renouncing the internet connection the installation procedure was able to continue - including creating new swap and primary partitions: system (/) and home (/home).

Thanks everybody for their quick responses. I do not know what the cause was and now i do not think it could be found.

It should be closed I guess but kept accessible for possible similar occurrence..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.