Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to disable automatically the laptop touchpad when I plug in a Wacom CTH-470L graphic tablet. I read here an answer about a touchpad-indicator, but it isn't available to 12.10.

I have also tried the gpointing-device-settings, but it doesn't provide such an option. Besides, there is a bug with this package regarding setting persistence after reboot.

I'm aware of the «Disable touchpad while typing» feature of the «Mouse and Touchpad» settings, but this is not what I'm looking for.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Create/edit this file

gksudo gedit /etc/udev/rules.d/01-touchpad.rules

Add this content

ACTION=="remove", SUBSYSTEM=="hid", RUN+="/sbin/modprobe psmouse"
ACTION=="add", SUBSYSTEM=="hid", RUN+="/sbin/rmmod psmouse" 
ACTION=="remove", ATTRS{idVendor}=="056a", RUN+="/sbin/modprobe psmouse"
ACTION=="add", ATTRS{idVendor}=="056a", RUN+="/sbin/rmmod psmouse"

You can find all information here: http://wiki.ubuntuusers.de/Touchpad in the section "Touchpad in Abhängigkeit einer Maus ein- und ausschalten".

Another way to solve the problem making use of phyton-scrips and synclient and examination of the content of mouse file in /proc/bus/input/devices is described here: http://wiki.ubuntuusers.de/Skripte/Touchpad-Verwaltung

share|improve this answer
    
The wiki you linked to is in German. Can you provide an English equivalent? –  Glutanimate Jan 13 '13 at 18:37
    
Sorry, I didn't find anything equivalent in English language. The interesting part of the article is under the headline "Touchpad in Abhängigkeit einer Maus ein- und ausschalten" and it says, you have to create a rule for UDEV. Create a file /etc/udev/rules.d/01-touchpad.rules and edit as root. paste the lines ACTION=="remove", SUBSYSTEM=="hid", RUN+="/sbin/modprobe psmouse" ACTION=="add", SUBSYSTEM=="hid", RUN+="/sbin/rmmod psmouse" and save. There must be synclient present in your system, if not, do sudo apt-get install gpointing-device-settings Quoted wiki.ubuntuusers.de/Touchpad –  diamy27 Jan 14 '13 at 6:05
    
Just found something in English language: brainstorm.ubuntu.com/idea/554 look for answer from "saivann (Brainstorm moderator) wrote on the 5 Mar 09 at 04:03" –  diamy27 Jan 14 '13 at 6:11
    
@diamy27 I've tested this and works flawlessly with the USB mouse, but not with the Wacom tablet –  Ed Villegas Jan 14 '13 at 18:49
1  
Maybe this could help: ACTION=="remove", ATTRS{idVendor}=="056a", RUN+="/sbin/modprobe psmouse" ACTION=="add", ATTRS{idVendor}=="056a", RUN+="/sbin/rmmod psmouse" since idVendor 056a is for Wacom. If not, replace HID with the aproppriate clue from the output of udevadm command. (you'll have to unplug the tablet first, then enter the udevadm monitor --environment command, and then plug the tablet again in order to get the udev events displayed.) –  diamy27 Jan 15 '13 at 15:00
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.