Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

after changing my video card to amd hd 6570 it's not possible to install Ubuntu anymore

On windows (8), everything is just fine. my new video card works perfectly and I have no problem with anything about it.

then when I try to boot from ubuntu (or any other Linux) to install it with wubi or with usb everything goes like this:

1) Grub problem at all, colors are just fine everything looks okay

2) and then Ubuntu's boot screen...weird background color, over the backround there are vertical stripes of red-orange dots.

3) desktop is about to start but * vertical stripes of red colored dots are all over the unity screen*. then when I click on ubuntu's menu, it usually switches to black screen saying something about "panic occured"...and then it restarts or it gives no respond at all.

problems started after I started using amd hd 6570 video card on my asus m5a78lm-lx mainboard which has amd phenom II X4 processor on it.

again, I'm writing on Windows 8 right now and everything works and looks perfect. so far I've only updated bios.

on virtual box Ubuntu works fine.

share|improve this question
Did you unintall the drivers for your old card? If you didnt that may be the problem. But unfortunately I don't know how to remove them via terminal. – Weylin Schreck Jan 13 '13 at 10:26
well sorry about that. I updated the title, now it's ok I guess. – Klyn Jan 16 '13 at 16:23

OK, did this using Linux Mint so should also work with Ubuntu. I used the compatibility mode to install Linux Mint and then installed the latest driver from AMD. So download these first onto an USB stick.

You need to switch to the console after the install pressing CTRL-ALT-F1. Now the console will also flicker now and then so you will need to concentrate when you type. Easy way out is probably installing the ssh-common package and to do it remote via ssh from another box or tablet even.

Now I'm not 100% sure if this was needed but I also ran "sudo apt-get remove fglrx" to remove any drivers which might be used. After that you'll need to reboot. Then switch to the console again and mount the USB drive "sudo mount /dev/sdb1 /mnt", unzip the zip file on the USB stick "unzip" and to run the file as root "sudo bash ./". It'll ask you a few questions, select the default answers and then reboot. Now the card should be working fine.

share|improve this answer
thank you, I'll try that with ubuntu. but has been a while since hd 6570 was released. why won't they try to fix it? :p – Klyn Jan 19 '13 at 22:36
up vote 0 down vote accepted

there was no fglrx to uninstall.

well I downloaded it, unzipped inside the usb with winrar and changed the complicated long..long file name to simply "run" so I wouldn't make mistake writing its name.

tried to mount it your way from ubuntu, didn't work, so I searched google and in there it told me to create a folder in media and mount it there with some parameters. I did, and I ran the bash command but it failed at some point while "unpacking" something.

i'm installing fglrx thing....AND DONE :P everything is alright no problem at all :D wth

thank you, bob

by the way if you have the same problem as mine, this is the next thing that might help you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.