Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently tried installing Ushare so I could share media between my laptop and Xbox. Could someone direct me as to how to change the settings so it can be recognized by my xbox.

Ushare.conf file:

USHARE_DIR=/home/travis/Music,/home/travis/Videos
USHARE_ENABLE_XBOX=yes
USHARE_ENABLE_DLNA=yes
USHARE_IFACE=wlan0

Every time I start the process running the command sudo service ushare start I get a crash report. If there is a way to copy this crash report tell me so I can post it.

ExecutablePath:
/usr/bin/ushare
Package:
ushare 1.1a-0ubuntu9
Title: ushare crashed with SIGSRGV in avformat_open_input()

share|improve this question
    
Updated in the Question section –  Travis Jan 13 '13 at 9:28
    
Looks like a problem with your /etc/ushare.conf file. Can you start ushare successfully from the command line? sudo ushare --content=<InsertYourMediaDirHere> –  Kevin Bowen Jan 13 '13 at 9:57
    
Please post the sections USHARE_DIR=, USHARE_ENABLE_XBOX=, and USHARE_ENABLE_DLNA= from your /etc/ushare.conf file. –  Takkat Jan 13 '13 at 9:59
1  
Also see: askubuntu.com/questions/89770/… –  Takkat Jan 13 '13 at 10:01
    
Ok I've got most things working with it my only problem now is that I can't get my Xbox 360 to "see" my laptop. –  Travis Jan 13 '13 at 10:34

1 Answer 1

To define a content directory when starting ushare as a service we have to edit the file /etc/ushare.conf as root (e.g. by running gksu gedit /etc/ushare.conf) and add the media directories separated with a colon like e.g.:

USHARE_DIR=/home/travis/Music,/home/travis/Videos,[...]

Replace travis with the name of your user.

We also need to make sure we use the appropriate network interface the xbox is attached to:

USHARE_IFACE=wlan0 # for wireless network 0, e.g eth0 when connected wired

In case we need to stream to a specific port (see xbox or router manuals for details on how to open ports) we can do so by defining this port:

USHARE_PORT=49200 # or any other port, if empty a random port is chosen

Alternatively we may run ushare from the command line using the following command:

ushare -D --name=<name_of_stream> --content=<path_to_mediafiles>

We can also define the interface, port, and more on the commandline (for all options see manual from GeeXboX).

share|improve this answer
    
This appears to have worked correctly on the computer but when searching for a pc on my xbox it is unable to find any. –  Travis Jan 13 '13 at 10:48
    
@Travis: what does the crash report tell you? –  Takkat Jan 13 '13 at 11:54
    
I have sent the error report. Is there a log that I can copy it from? –  Travis Jan 13 '13 at 11:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.