Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have run into a very odd problem in Kubuntu 12.10. Whenever I add a program through Muon or `apt-get`, it doesn't show up in the menu. For example, I installed Opera from a deb package and Code::Blocks from the repositories, and neither of them are in the menu. I can open them from the command line.

I opened KMenuEdit, and they weren't there. I tries adding them, but when I pressed save, it said it was updating the configuration. Whenever the progress bar reached 90%, it reset to 0%. Here is the output in the termnal:

kmenuedit(18316)/kdecore (services) KServicePrivate::init: The desktop entry file  "/home/andrew/.local/share/applications/Opera.desktop"  has Type= "Application"  but no Exec line 

Could not resolve property : pattern6664
Could not resolve property : linearGradient4636
Could not resolve property : linearGradient4592
Could not resolve property : linearGradient4247
Could not resolve property : linearGradient11897
Could not resolve property : linearGradient11897
couldn't create image from  "" 
Could not resolve property : linearGradient5167

If I view Opera.desktop, the exec line is Exec=opera.

I am using KDE 4.9.5 from the kubuntu-ppa/ppa repository.

Edit

My /home/andrew/.local/share/applications/Opera.desktop looks like this:

[Desktop Entry]
Comment=
Exec=opera
GenericName=Web Browser
Icon=opera-browser
Name=Opera
NoDisplay=false
Path[$e]=
StartupNotify=true
Terminal=0
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=

and my /usr/share/applications/opera-browser.desktop looks like this:

[Desktop Entry]
Type=Application
Version=1.0
Name=Opera
GenericName=Web browser
GenericName[bs]=Web preglednik
GenericName[de]=Web-Browser
GenericName[eo]=TTT-rigardilo
GenericName[es]=Navegador web
GenericName[et]=Veebibrauser
GenericName[eu]=Web arakatzailea
GenericName[fi]=WWW-selain
GenericName[fr]=Un navigateur web
GenericName[is]=Vafri
GenericName[it]=Browser Web
GenericName[nb]=Nettleser
GenericName[nl]=webbrowser
GenericName[nn]=Nettlesar
GenericName[pt]=Navegador Web
GenericName[pt_BR]=Navegador
GenericName[ro]=Navigator de web
GenericName[ru]=Веб-браузер
GenericName[sl]=Spletni brskalnik
GenericName[ven]=Buronza ya Webu
GenericName[xh]=Umkhangeli Zincwadi Zokubhaliweyo
GenericName[zu]=Umkhangeli zincwadi we Web
Comment=Fast and secure web browser and Internet suite
Icon=opera-browser
TryExec=/usr/bin/opera
Exec=/usr/bin/opera %U
Terminal=false
MimeType=text/html;text/xml;application/xhtml+xml;text/vnd.wap.wml;text/wml;application/x-mimearchive;application/mime;application/xml;application/rss+xml;application/rdf+xml;image/svg+xml;application/x-opera-extension;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/mailto;video/ogg;audio/ogg;video/webm;image/webp;
Categories=Network;WebBrowser;
StartupNotify=true
X-AppInstall-Package=opera
share|improve this question

1 Answer 1

Edit: On further reflection, I'm quoting partly from the first line of code you provided:

The desktop entry file  "/home/andrew/.local/share/applications/Opera.desktop"  has Type= "Application"  but no Exec line  

It looks like you maybe having two opera.desktop files: one in ~/.local/share/applications and the other in /usr/share/applications. My understanding is that the first takes precedence but it's possible some weird confusion may be occurring?


Please look at Opera.desktop again. See if you find a line, or lines, like this:

OnlyShowIn=Unity

A list of other OnlyShowIn= options is here.

If there is such a line, open Opera.desktop with a text editor (and sudo) and comment out that line by adding #. Save the file. You may now see Opera in your menu.

You can read more on the subject here. The "opposite" of OnlyShowIn= is NotShowIn= and if there's a line like NotShowIn=KDE that could be to blame.

And you may need to refresh things by running

sudo update-desktop-database

according to this answer.

Of course, it's entirely possible that there's some other solution altogether!

share|improve this answer
    
There is an opera-browser.desktop in /usr/share/applications. I think that the ~/.local/share/applications/Opera.desktop was generated by KMenuEdit. Also, when I run sudo update-desktop-database, I get a command not found error. –  Orcris Jan 13 '13 at 16:56
    
I'm out of my depth here. I don't have KDE installed. You may consider asking at kubuntuforums.net/forum.php and if you come up with a solution you could post it here and accept your own answer. –  user25656 Jan 13 '13 at 17:09
1  
Ok. Thanks for the answer. –  Orcris Jan 13 '13 at 17:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.