Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had recently bought a Dell Inspiron 7520 laptop , Which was pre-loaded with windows 8. I wanted to set up dual boot with Ubuntu 12.10 . I am having the following issues . Any help will be really appreciated .

1) I was not able to start ubutu 12.10 live CD in UEFI mode. I am not able to find any bios setting to do so . The bios firmware version , thats been loaded with the laptopn is A07.

2) As a result , I have to install ubuntu in legacy mode , which naturally does not detect the windows 8 installation . After installing Ubuntu , I tried using boot-repair to convert the legacy installation to UEFI mode . But the boot-repair failed with the following error . http://paste.ubuntu.com/1525014/

3) I am not sure , how to go ahead from here. Any help will be really appreciated .

share|improve this question
    
Possible duplicate of askubuntu.com/questions/221835/… –  Eliah Kagan Jan 13 '13 at 4:47
    
Possibly not ... I think i tried the same thing explained in that post... I could able to disble uefi and boot live CD in legacy mode.But the issue is after installing boot repair was not able to convert the legacy installation to UEFI thing.. –  itmpras Jan 13 '13 at 12:20
add comment

2 Answers

maybe a stupid answer, but you can give it a try:

windows 8 doesn't shut down as it used to in the previous versions (it hibernates instead) - this can cause some issues.
so instead of just clicking shutdown in win8 charms you should try to type "cmd" (without quotation marks) when in start screen - this opens the command prompt - then type following command:
"shutdown -s -t 0"
(again without quotation marks) and hit enter.
this shuts your system down as it used to - afterwards you can try to reinstall ubuntu, maybe it works.

btw: this also works if you cannot access/mount your windows8 partition within ubuntu

share|improve this answer
add comment

I have the same laptop and was able to setup dual boot. It seems strange that you can't boot in UEFI mode, are you trying to get the system to auto-detect the DVD and boot, or are you hitting F12 and selecting the DVD from the boot menu? I've been using a USB and F12 method to UEFI boot.

I've also disabled secure boot in the BIOS. I don't believe this affects the ability to boot from DVD or USB, but it does affect the next part.

Once booted, I did a standard install with custom partitioning, this installs grub-efi which then becomes the default bootloader and will boot automatically into Ubuntu. Instead of running boot-repair as many guides suggest, I simply manually added an entry for the Windows8 EFI partition as shown in this guide:

http://www.timmeredith.com/tutorials/windows-8-grub.php

I believe that's all I did to get dual-boot working, hopefully it works for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.