Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to linux/ubuntu and I have encountered a little problem: After installing x2x (following ubuntu community documentation about x2x) my laptop keyboard no longer works. The x2x system worked great - I was able to control my laptop from the desktop which was ssh'd into it... but the keyboard on the laptop no longer works. I have a dual-boot, and when I boot into lion (it's an early 2008 macbook) the keyboard works fine. Also, if I use a wireless usb mouse/keyboard when in ubuntu they work... just the actual computer hardware doesn't. Help?


  • Installed x2x, worked great
  • Now the keyboard on my laptop dosen't work when logged into Ubuntu, but works in native OS (mac, lion)


Additionally, if I log into a guest account in Ubuntu they keyboard works fine... So I'm assuming there's something wrong just in my main account.

share|improve this question
Also, here are the instructions I followed for x2x: – Pseudo_Scientist Jan 12 '13 at 22:35
You can always edit your question to give additional information. – guntbert Jan 12 '13 at 22:41
up vote 2 down vote accepted

If anyone runs into this problem it turns out I accidentally hit NumLock on the keyboard that was ssh'd into my mac. Hitting numlock again fixed the issue. I'm not a smart man...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.