Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Upgraded from 10.04 to 10.10 removed hibernate option for me and introduced the problem where by after entering standby (being indicated by blinking amber LED on my laptop) I cannot resume my session. Instead I get a crash and system reboots (crash comes instantly on trying to resume).

Tried clean install to eliminate possibility of an upgrade issue but its still persistent. All latest updates installed.

Tried looking for an answer to this but still no joy. Laptop is Sony VGN-FW41E.

share|improve this question
    
did you ever get this solved? How? Please update (or delete?) your question - thanks! –  Torben Gundtofte-Bruun Feb 18 '11 at 7:22
    
I have exactly the same problem. I have a Sony VAIO VGN-FW25G laptop. Though i have noticed that whenever the laptop restarts on trying to resume, its volume is muted. –  user11252 Feb 22 '11 at 11:14
add comment

4 Answers

If the solution below does not work for you, try this one:

  • Edit the file /etc/default/grub (as root)
  • Change the line with:

    GRUB_CMDLINE_LINUX=""
    

    to:

    GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"
    
  • run update-grub (as root)

Worked for me... Hope this can help you!

share|improve this answer
    
Works perfectly on my Sony Vaio F11. Thanks a bunch! –  jfoucher May 13 '11 at 21:33
add comment

this worked for mi before i install ati drivers
Edit the file /etc/default/grub (as root)

Change the line with:

GRUB_CMDLINE_LINUX=""

to:

GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"

run update-grub (as root)

and this ohter one worked just fine after installing the ati drivers

"I've solved a similar issue (reboot on resume) with a Sony Vaio VGN-FW51ZF by changing the last line of the file /etc/acpi/sleep.sh from pm-suspend to pm-suspend --quirk-radeon-off (guess it was a problem related with ATI proprietary drivers)."

so thanks for those tips and i hope this save you some time

share|improve this answer
add comment

I've solved a similar issue (reboot on resume) with a Sony Vaio VGN-FW51ZF by changing the last line of the file /etc/acpi/sleep.sh from pm-suspend to pm-suspend --quirk-radeon-off (guess it was a problem related with ATI proprietary drivers).

Hope this can help you!

share|improve this answer
add comment

Sry for reviving an old thread, but you guys gave me the solution I was looking for

After some change I wasn't able to backtrack my S2R went south

Hibernation was still working but S2R no. Since trying to awake the system led to a reboot I wasn't ablle to debug either.

Adding the "acpi_sleep=nonvs" boot parameter solved the problem: Now S2R works from inside KDE, from command line, from wherever I invoke it

Thanks a lot

Just for reference: Laptop: Vaio VPCEA1S1E

vga: 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4500/5100 Series]

CPU vendor_id : GenuineIntel cpu family : 6 model : 37 model name : Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.