Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed burg on my computer, and after restarting, grub comes up with the following message:

GRUB loading.
error: no such device: 9b16030c-08f8-4f5d-b228-63e13bca7839
Entering rescue mode...
grub rescue>

typing the ls command will bring me this:


This is probably wrong, Ive seen people have many more listings when doing that command.

when I type the command set, it comes up with:


I have tried the commands:

set prefix=(hd0,x)/boot/grub set root=(hd0,x) insmod normal normal

I have tried pretty much every variation of that code, I do not get errors on the set prefix and the set root commands, but when I try any variation of the Insmod command, then it comes up with either the error Unknown partition or Unknown filesystem

Variations tried of the insmod command

Insmod (hd0,x)/boot/grub/normal.mod

This comes up with the unknown partition error

Insmod normal

This comes up with the unknown filesystem error

The unknown partition error seems to appear when (hd0,x)/boot is specified

I have tried booting from a cd and it doesn't seem to work.

I am dual booted with windows 7 and ubuntu 12.04 How can I recover from this situation?


share|improve this question

user121839 is correct.

I had a similar issue on a system where I'd moved the partitions around, and ls listed all of my partitions, not just the drive (hd0).

For the benefit of future googlers:

Upon hitting

grub rescue>

Run ls to get a list of drives and partitions, for example:

(hd0) (hd0,msdos1) (hd0,msdos2)

If you only see (hd0) then you probably need to examine the drive with another computer or a Live boot.

Run set to get a look at your current boot settings:


If you have a system and a swap partition and grub is trying to boot from the swap (as with my situation), this might be the sort of issue you see.

You can use cat and ls to examine files or check for their existence:

ls (hd0,msdos1)/boot/grub/
cat (hd0,msdos1)/boot/grub/grub.cfg

Set the correct boot partition. Note: I did not use set, just typed the environment assignments in directly (prefix=value).

set prefix=(hd0,x)/boot/grub
set root=(hd0,x)

Then load grub to boot.

insmod normal

I hope that's helpful, citizens of the future.

share|improve this answer

This is probably wrong, Ive seen people have many more listings when doing that command.

Yes it should at least list all the partitions on that drive.
But it looks like your disk is just empty (no partition table) or at leat GRUB can't find anything (wrong grub-configuration).
Have you tried to boot a LiveCD/USB and check your drive?

I have tried booting from a cd and it doesn't seem to work.

If you realy can't even boot from CD/USB means the problem might be your bios settings.

share|improve this answer
THanks for the input i think that booting from a cd and uninstalling burg might be the best option, I'll look into booting from the cd more, I haven't researched that hardly at all yet. – chickengod27 Jan 13 '13 at 4:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.