Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on a general energy saving mission. I've finally swapped my old CRT monitor for a LCD, so the next step it to optimise the PC power usage. It's using an AMD 64 X2 4600+ CPU which I know can trottle down, but seems to be running at a constant 2.4GHz.

A while back I heard about Granola. I've installed it, but when I try to run it (via sudo granola) I get

granola[10568]: Error opening scaling governor file '/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor' in read mode
granola[10568]: Is cpufreq enabled in this kernel and do you have a CPU which supports DVFS?
granola[10568]: Can't manage DVFS for any CPUs

I'm happy to use other applications if Granola is not optimal or viable, but am not looking to invest in new hardware just now.

Running kernel 2.6.35-25-generic

share|improve this question
    
Can you please provide some additional information: Are the lines you quote the only messages relating to granola? Which kernel version are you running? –  jstarek Jan 30 '11 at 21:41
    
Unrelated to using granola: I recently was able to use a decent true RMS multimeter to do some measurements on a mixed set of hardware and found that using an efficient PSU has a great energy saving potential. The greatest difference in my test field was 30%, far larger than what is possible by CPU throttling. –  jstarek Jan 30 '11 at 21:44
    
Those were all the errors from Granola. Running kernel 2.6.35-25-generic. A new PSU may give greater savings, but this question is about what I can do without buying new hardware. –  steevc Jan 30 '11 at 22:01
    
are you running granola as root? granola will have to be root if it needs access to kernel tuning things. –  user1974 Jan 31 '11 at 2:09
    
Hmm -- I thought granola started itself at boot time? –  belacqua Feb 4 '11 at 10:36
add comment

4 Answers

You Can Use Jupiter

Jupiter is an applet which allows you to switch between maximum and high performance and power saving mode, change the resolution and orientation, enable or disable the bluetooth, touchpad, WiFi and so on.

You can install by adding the ppa ppa:webupd8team/jupiter and installing jupiter from the software center.

share|improve this answer
add comment
up vote 1 down vote accepted

I'm not sure what the exact sequence of events was, but I just noticed that granola is running now. I know I tried installing cpufreqd and powernowd, but either caused Granola to be uninstalled. It may just be that the PC needed to restart.

It would be nice if the app showed more details about how often the CPU is being throttled and to what speed. I can see current speed with

cat /proc/cpuinfo

and to time at each speed with

cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state

I'm assuming both cores run at the same speed. That shows speeds from 1-2.4GHz with most time spent at the lower speeds. I have a whole-house power meter. I'll see if that can tell me the difference the speed makes.

Update: I was too quick to celebrate. Today it's not working. I looked in /var/log/messages and found this for yesterday

Feb  4 07:50:20 zaphod kernel: [    0.560856] powernow-k8: Found 1 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+ (2 cpu cores) (version 2.20.00)
Feb  4 07:50:20 zaphod kernel: [    0.560910] powernow-k8:    0 : fid 0x10 (2400 MHz), vid 0xc
Feb  4 07:50:20 zaphod kernel: [    0.560912] powernow-k8:    1 : fid 0xe (2200 MHz), vid 0xe
Feb  4 07:50:20 zaphod kernel: [    0.560914] powernow-k8:    2 : fid 0xc (2000 MHz), vid 0x10
Feb  4 07:50:20 zaphod kernel: [    0.560917] powernow-k8:    3 : fid 0xa (1800 MHz), vid 0x10
Feb  4 07:50:20 zaphod kernel: [    0.560919] powernow-k8:    4 : fid 0x2 (1000 MHz), vid 0x12

For today there is just the first of those lines. That suggests something went wrong, but where do I see the errors? Restarted and it was ok.

share|improve this answer
    
May I suggest powertop. Run it on a mostly idle system, and it tells you how many percent of the time the CPU spends in the different states and the primary causes for wakeups. I doubt that you will see anything on a whole-house powermeter; using a wall plug meter I get 2-5 W difference at best with an Intel i3. Combined with managing hard drive sleep I get decent savings percentage-wise, but you would have to use very little electricity elsewhere for it to make a dent in the whole-house consumption. –  j-g-faustus Feb 4 '11 at 22:20
add comment

This page offers some suggestions: http://grano.la/help/install.php

Have you verified that those cpufreq files and folders mentioned in the error file exist?

Also, ensure that DVFS is enabled in the BIOS http://grano.la/help/wiki/doku.php?id=bios

Also have you tried just adding the "CPU Frequency scaling monitor" applet in Gnome? I believe the cpufreq module is part of the kernel now, so it just works for me.

share|improve this answer
    
I've read those. I don't have the cpufreq folder, which makes me think I'm lacking some kernel option or driver. I tried installing cpufreqd and powernowd, but either causes Granola to be uninstalled as it seems only one frequency scaling daemon can be installed at any time. That makes some sense. I'm using KDE. I used an applet for that years ago, but need to check what it was. –  steevc Jan 31 '11 at 13:19
add comment

I installed granola and found the GUI to be pretty but lacking any really useful information. I would much prefer to see what it is actually doing in terms of frequency scaling than how many trees it is saving!

I have now opted for powernowd (you have to uninstall granola first, since you can only have one power management daemon runnin at once. Otherwise the two could be pulling the CPU frequency in opposite directions).You can install powernowd Install powernowd from the software center.

This appears to be lightweight and gets the job done. I can monitor the current CPU frequency on each core by adding the "CPU frequency scaling monitor" applet to my Gnome panel (I think it comes pre-installed with the Ubuntu 10.10).

Now my Intel Q6600 (4 x 2.4GHz) spends most of its time at 4 x 1.6GHz.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.