Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu onto a new SATA drive. I'm using a LinuxLive USB stick with 12.04. During the install process it gets to the step where it asks me to pick a root partition, no hard drives are displayed.

I'm using an ASUS A7VBX mobo: http://www.mxdatarecovery.net/asus-motherboard-socket-462--a7v4627.html which has 2 SATA 1.5Gb ports. I've tried both ports with 2 different drives, an OCZ Agility 3 SSD, and a mechanical Toshiba 500GB. I've even tried a PCI SATA expansion card, and nothing.

In the BIOS there is no mention of AHCI, but the hard drive controllers have 'Access Mode' options of CHS, LBA, Large, and Auto. Is this relevant?

The drive currently in there is badly scratched and slow, even on Ubuntu, so I'd really like to replace it.

Thanks for any ideas.

share|improve this question
    
I saw a topic like this a few days ago. You probably need to use the alternate CD (not the live CD) and pre-load the driver for your controller(so not the hard disc). –  Rinzwind Jan 12 '13 at 18:26
    
If you are trying to install from the standard CD you could also use the Live System to test. –  guntbert Jan 12 '13 at 21:23
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.