Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Google Chrome 24.0.1312.52 (it happens on older Chrome versions too) on Ubuntu Precise with Shockwave (Pepper) Flash 11.5 r31. Occasionally the sound of the Flash player breaks and remains broken until I restart my system. This happens especially often when I play videos from epicfail dot com. Like every second video or so.

By "broken" I mean that it sounds like... er... well... farting. While it does seem to have something to do with the actual video sound (in terms of volume for example) it is absolutely unintelligible.

When the Flash sound is broken, it is broken for every flash instance - videos, games, etc. Restarting the browser or shift-esc -> plugin-shockwave-flash-> end-process does NOT fix it. The sound in other applications (Rhythmbox, Movie Player, Installed games) works fine. Only Flash seems to be affected.

Restarting the computer fixes it (until it gets broken again). So far it hasn't happened if I'm watching Youtube videos or playing Kongregate games. Epicfail is the surest way to break it, and it does happen every once in a while after a Wimp video.

So, has anyone experienced this? Is there a way of fixing it, or if not, at least getting it to work again without having to restart my machine?

share|improve this question
    
The latest Chrome stable is 24.0.1312.52. Maybe you could try that? –  user25656 Jan 12 '13 at 17:40
    
no luck there too –  Borislav Stanimirov Jan 15 '13 at 9:42

3 Answers 3

up vote 1 down vote accepted

Just want to say that I ran into this problem and the solution was unexpected so I thought I'd share here.

There was another process using pulseaudio (a CLI music app) that starts on bootup, and I just have it paused when not using it. This process was monopolizing the flash player and preventing my browser from playing sound.

If anyone else runs into this, make sure to check and see if you have any other apps/processes using flash.

share|improve this answer

Try restarting pulseaudio by sending a regular SIGTERM signal to it (it will recover). In the terminal run:

killall pulseaudio

That tends to fix the problem for me.

One more option is going to chrome://plugins (location bar), and disable "pepperflash".

share|improve this answer
1  
I'm running Google Chrome too, but I don't have this "pepperflash" entry in the list of plugins. Perhaps you just mean the "Adobe Flash Player" entry? –  gertvdijk Feb 8 '13 at 22:33
    
Well recently the problem just disappeared. I don't know what specific update fixed it. Should I delete the question? –  Borislav Stanimirov Feb 16 '13 at 10:42

I had the same symptom on Chrome v 26.0.1410.63 on Ubuntu 10.04. I have two Adobe Flash plugins registered in Chrome (both were enabled). When I disabled /opt/google/chrome/PepperFlash/libpepflashplayer.so (version 11.7.700.169) and left /usr/lib/adobe-flashplugin/libflashplayer.so (version 11.2 r202) enabled, the problem was fixed. I didn't even have to restart the browser.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.