Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to setup Canon InkJet Pixma IP 1300 on Quantal AMD64. The things I have tried:

  • Shut down and disconnect the printer before installing packages.
  • Added the ppa:michael-gruz/canon repository to synaptic and installed the cnijfilter-pixmaip1000series package (there is no package for 1300 so I installed the nearest one). The PPA repository does not have packages for Quantal, so had to manually update the repository definition to "Oneiric" and refreshed it before downloading.
  • Restarted cups via sudo service cups restart.
  • Connected and switched on the printer.
  • Opened All Settings -> Printers to Add a printer. There are 2 entries - One for the Standard USB Printer, another for "USB Printer - With Status Readback for Canon IJ" with Device URL as cnijusb:/dev/usb/lp1. Have selected this as per direction in Ubuntu Community Forum.
  • For manually entering a .ppd file I select /usr/share/cups/model/cnpixmaip1000.ppd.

    ERROR MESSAGE : Failed to read PPD file. Possible reason follows: /usr/share/cups/model/cnpixmaip1000.ppd: FAIL*FAIL* Unable to open PPD file - No such file or directory on line 0.

  • On checking I find that cnpixmaip1000.ppd file in /usr/share/cups/model is a symbolic link pointing to /usr/share/ppd/cnpixmaip1000.ppd.

However the later file does not exist. There are no other ppd files installed.

PS: Printing works fine with the shareware TurboPrint for Linux. So, there's nothing wrong with the printer.

share|improve this question
    
This works for Canon PIXMA IP1300 on Ubuntu 13.04 64 bit –  user179130 Jul 28 '13 at 9:17

3 Answers 3

Just installed the same printer on Quantal 32bit edition (canon pixma IP1300).... These are the steps you should try:

1) Add repo:

sudo add-apt-repository ppa:michael-gruz/canon-stable

2) Remove the printer installed in cups. And disconnect the printer.

3) sudo apt-get install cnijfilter-ip2200series

4) restart cups:

sudo service cups restart

5) chose printer ppd driver when installing the printer:

/usr/share/cups/model/canonip2200.ppd

6) print test page > succes.

Hope i helped you.

share|improve this answer
    
This works for Canon PIXMA IP1600 on Ubuntu 13.04 –  Torbins Apr 26 '13 at 19:44

August 2014 update:

The above answer (by hellyeah) worked for me for Canon PIXMA iP1600 (with 64 bit Ubuntu), with the exception that in step 1 I had to instead do:

sudo add-apt-repository ppa:michael-gruz/canon-trunk
sudo apt-get update

Hopefully this saves someone some time.

share|improve this answer

For anyone stuck on stage 5, installing the printer means:

1 - Go to localhost:631

2 - Go to administration and enter your OS user and password

3 - Click on the Add Printer button (with the printer plugged in)

4 - Select your printer from the local printers

5 - Press continue

6 - Press continue

7 - Where it says Or Provide a PPD File, click Choose File and navigate to & select: /usr/share/cups/model/canonip2200.ppd

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.