Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been testing Ubuntu 12.10 on my Thinkpad T420 (with nvidia optimus, yes) and over the last couple of days I've made 10-20 clean installs. Every install I've (until now) has had the brightness hot keys working out of the box. But this morning I've made two new clean installs (using the same media as always) and not the hot keys do not work out of the box. I am able to adjust the brightness by going to "System settings" -> "Brightness and Lock", but the hot keys (Fn + Home/End) simply does not work. I have installed nothing but bare Ubuntu (no nvidia drivers, nothing). I am certain this used to work for me (clean install, hot keys working of the box) because I ran a series of power tests using "powerstat" on both clean installs, installs with drivers, installs with bumblebee etc. and they were all made with minimum brightness - hence they hotkeys have worked for me on clean installs just a couple of days ago.

What could have gone wrong and how to I start to debug?

share|improve this question

closed as too localized by jrg Jan 25 '13 at 18:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

After similar to 5 restarts it all of a sudden works again. Animation and the actual brightness adjustments. So problem solved.

I however still do not get how 2-3 clean installs had it not work until after ~5 restarts while other clean installs did.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.